Mopidyctl dont take the config (tryes to anoy me as a service)


#1

My Goal is to feed my Chromecast Audios a playlist via Home Assistant
(turn on the lights, heat up the kettle and play some music in the bath)

It took a while to understand that Mopidy as a service uses another config file =P
so i go to
sudo nano /etc/mopidy/mopidy.conf
link https://hastebin.com/guhifitoqa.makefile
There i make all my funny settings to get the icecast stram and most importand the [musicbox_webclient]

when I’m now open
sudo mopidyctl config
https://hastebin.com/akopegiquc.makefile
where the hack is [musicbox_webclient] gone to?..

sudo service mopidy restart dont help as well… somebody a idea?
when i stop the service and start it via the shell its working fine but defeats the purpose.


#2

I think the output of sudo mopidyctl deps would show that the Mopidy system service cannot find musicbox-webclient installed. You need to install it using sudo pip install mopidy-musicbox-webclient it you want the system service to be able to find it.

Lastly, the musicbox option is for PiMusicbox installations only, do you really want that? Otherwise none of those musicbox-webclient options you’ve specified are actually required since they are all the default values.


#3

but but but… That was the way i installed this?.. I realy dont get it… but now it shows up in deps.
the musicbox option was one of the many tries to get it working. i bet it disapiears again :sweat_smile:
3/4 of the day to set mopidy up ^^

now i only have to find out how to call the api to play playlist 1!