Google Play Music - working?

Curious to know if anyone has Google Play Music working in Mopidy? I tried a bunch of different things to get it working and can’t find any recent posts about it working or not working.

Wondering what I’m doing wrong?

It certainly works. You’ll have to provide more details.

Oh yeah? OK, well that’s good to know. I’ve added the correct lines to the mopidy.conf file. I’ve tried several options for the deviceid (I’ve used botth the Android Device ID and GSF as per other posts I read), ensured that I setup a two-step auth password, etc. Yet, once I load up a client, I have no option for GMusic.

The first step is usually to check you are editing the correct config file. If you are running Mopidy as a service then it’s ‘mopidyctl config’, otherwise just ‘mopidy config’. Use that to double check the config settings you think you are setting are actually being read.

You should also have a look in the log file for any clues as to what is happening. For the debian service it’s located at /var/log/mopidy/mopidy.log. It should print out what error is occurring and give you some hints.

I’m pretty sure I’m running it as a service – I followed to doc so that it loads when my Pi reboots; does that indicate that it’s set to run as a service?

I don’t see anything in the logs about GMusic, though the rest of the config file seems to be read.

I wasn’t able to find mopidyctl.config. Where is it supposed to be located?

Yes, if it starts on boot then it’s running as a service. The command is ‘mopidyctl config’.

Ah, OK. So how do I modify this config? Here’s the lines I get re: GMusic on output of that command.

enabled = false  ; Extension disabled by self check.

You edit /etc/mopidy/mopidy.conf as usual but I would really expect there to be something in the log to explain why it’s disabled. Could you provide your full log file (use

Seeing a GMusic error now related to the python version.

This did the trick:

pip install pyasn1==0.1.8