MusicBox Webclient not running

First, it seems like there is a lot of questions around the web client and I’ve read every post here and and it didn’t resolve my issue.

I’ve just installed Mopidy, can connect to the landing page no problem. Added the Musicbox Webclient and the Mopidy service will not load it upon starting.

What I’ve done…

  1. The Musicbox Pip install ran no problem
  2. Added the web client settings in Mopidy.conf
  3. Restart the service and Run the Mopidyctl config file and it does not load the web client, those settings are omitted from the running config
  4. Confirmed I am getting the right config file (renamed the one in the user directory and also tweaked port settings and then put them back just to be sure I was not missing anything obvious)

Any other thoughts?

https://docs.mopidy.com/en/latest/troubleshooting/

  1. exactly how did you install the extension? Provide the command you used.

  2. You don’t need to edit any config files to install this webclient, but since you did, which config file did you edit?

  3. Like we always ask, provide the output of sudo mopidyctl deps.

Are you sure this isn’t the usual problem of installing without using sudo or installing an extension with the wrong version of pip which installs it using the wrong version of Python? What operating system are you using?

Thanks for the response.

  1. Here is the command, I just reran it also to capture the output below. If I add in the Sudo -H flag I don’t receive the permissions issue on the ./cache folder

sudo python3 -m pip install Mopidy-MusicBox-Webclient

kane@Server:/etc/mopidy$ sudo python3 -m pip install Mopidy-MusicBox-Webclient
The directory ‘/home/kane/.cache/pip/http’ or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
The directory ‘/home/kane/.cache/pip’ or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
Requirement already satisfied: Mopidy-MusicBox-Webclient in /usr/local/lib/python3.6/dist-packages
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from Mopidy-MusicBox-Webclient)
Requirement already satisfied: Mopidy>=1.1.0 in /usr/local/lib/python3.6/dist-packages (from Mopidy-MusicBox-Webclient)
Requirement already satisfied: tornado>=3.2 in /usr/local/lib/python3.6/dist-packages (from Mopidy>=1.1.0->Mopidy-MusicBox-Webclient)
Requirement already satisfied: requests>=2.0 in /usr/lib/python3/dist-packages (from Mopidy>=1.1.0->Mopidy-MusicBox-Webclient)
Requirement already satisfied: Pykka>=1.1 in /usr/local/lib/python3.6/dist-packages (from Mopidy>=1.1.0->Mopidy-MusicBox-Webclient)
kane@Server:/etc/mopidy$ sudo python3 -m -H pip install Mopidy-MusicBox-Webclient

kane@Server:/etc/mopidy$ sudo -H python3 -m pip install Mopidy-MusicBox-Webclient
Requirement already satisfied: Mopidy-MusicBox-Webclient in /usr/local/lib/python3.6/dist-packages
Requirement already satisfied: Mopidy>=1.1.0 in /usr/local/lib/python3.6/dist-packages (from Mopidy-MusicBox-Webclient)
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from Mopidy-MusicBox-Webclient)
Requirement already satisfied: Pykka>=1.1 in /usr/local/lib/python3.6/dist-packages (from Mopidy>=1.1.0->Mopidy-MusicBox-Webclient)
Requirement already satisfied: tornado>=3.2 in /usr/local/lib/python3.6/dist-packages (from Mopidy>=1.1.0->Mopidy-MusicBox-Webclient)
Requirement already satisfied: requests>=2.0 in /usr/lib/python3/dist-packages (from Mopidy>=1.1.0->Mopidy-MusicBox-Webclient)
Kane@Server:/etc/mopidy$ sudo systemctl restart mopidy

  1. Added this to /etc/mopidy/mopidy.conf. Thought that was noted in one of the support tickets. It was failing with or without it but I’ll certainly remove if it is wrong. I was expecting to see this noted in the mopidyctl config output but it wasn’t.

[musicbox_webclient]
enabled = true
musicbox = false
websocket_host =
websocket_port =
on_track_click = PLAY_ALL

  1. After I posted this I ran through it some more and realized it was not in the dependancies…

sudo mopidyctl deps
Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf deps” as user mopidy
Executable: /usr/bin/mopidy
Platform: Linux-4.15.0-106-generic-x86_64-with-Ubuntu-18.04-bionic
Python: CPython 2.7.17 from /usr/lib/python2.7
Mopidy: 2.1.0 from /usr/lib/python2.7/dist-packages
GStreamer: 1.14.5.0 from /usr/lib/python2.7/dist-packages/gi
Detailed information:
Python wrapper: python-gi 3.26.1
Relevant elements:
Found:
uridecodebin
souphttpsrc
appsrc
alsasink
osssink
oss4sink
pulsesink
id3demux
id3v2mux
lamemp3enc
mpegaudioparse
mpg123audiodec
vorbisdec
vorbisenc
vorbisparse
oggdemux
oggmux
oggparse
flacdec
flacparse
shout2send
Not found:
flump3dec
mad

Mopidy requires Python 3.7 and Ubuntu 18.04 provides Python 3.6. You can see your Mopidy service is using Python 2.7.