Issues with access and configuration after moving over to running it as a service



Yesterday I fought for many hours to get Mopidy up and running. At 05:00 I called it a day and went to bed after getting it to run successfully on my RPi, being able to stream radio and music from my local music folder from a MPD client as well as from home assistant. Before going to bed I decided to start running it as a service and followed this: and went to bed.

When I got up, nothing really worked. Couldn’t access it from anything but localhost and it had access to no radio streams nor music files. I managed to add things through MPC and gave it access to pulseaudio so that I could stream radio by using MPC. But when I tried changing the config files to make it accessible from other units in the network, something weird happened. First of all, it doesn’t seem to be using the config file from my ~/.config/mopidy/ directory any more. I tried removing it as well as the on in /etc/mopidy and nothing happens. It seems to ignore both those mopidy.conf files and loads some default that show up when I type “sudo mopidyctl config”. I don’t know where it loads this from and I can only access the Mopidy server through clients on other networks, not localhost (by using MPC) any longer.

It feels like I have three issues, I need to figure out where the config file is loaded from since it’s neither /etc/mopidy or in ~/.config/mopidy. I am at a loss of how to even start to change and experiment. Secondly I have to make it accessible to other units and localhost simultaneously. Also I need to make it be able to access music like before. Can anyone help me out with this or point me in any helpful direction?


I just realised that after I move the config files, it creates a default one. Both in my /etc/mopidy and ~./config/mopidy. But there is nothing in /etc/mopidy (mentioned when I do sudo mopidyctl config) that mentions that it should be using the home directory config? How does all this really work?


It’s explicit at

All configuration is in /etc/mopidy/mopidy.conf, not in your user’s home directory.

It also explicitly says what config files are being read in the log during startup.