Mopidy/gmusic extensions persistently using default configurations


I’m trying to get Mopidy running on a RP3b+ (Raspbian stretch) with the MusicBox webclient and gmusic extensions. Everything is working ok except that I’m having a problem with the configuration files. I set mopidy to run as a service with systemd, edited /etc/mopidy/mopidy.conf to my desired settings, checked permissions to make sure it was accessible and tested the service. When I restarted the mopidy service and ran mopidyctl config, I saw the builtin default settings for each extension, which I thought was curious, so I restarted the system and saw the same thing. I proceeded to check ~/.config/mopidy and copy my mopidy.conf there, and checked again–still the builtin defaults. I checked the user and system versions of mopidy config again, looked at all referenced filepaths, proceeded to search my whole filesystem for anything called mopidy.conf, and found nothing. Editing settings though the webclient seems to alter /etc/mopidy/mopidy.conf, but have no affect on the actual settings used by the mopidy service. For troubleshooting purposes, I even switched to the mopidy user, manually started mopidy explicitly only calling out /etc/mopidy/mopidy.conf and got the same builtin defaults. Any ideas? Am I doing something idiotic? :wink:

Thanks in advance!

I am not sure what is going wrong here. You are right that the service will use /etc/mopidy/mopidy.conf. Apologies if this is obvious but sometimes people don’t realise lines prefixed with a ‘#’ character are comments and are ignored; have you made sure your config lines are not all commented out?

Are there no error messages in the mopidy logfile?

Could you paste your /etc/mopidy/mopidy.conf file (with any private info removed)?

The only other thing I can think of is the file permissions, presumably you have:

$ ls -l /etc/mopidy/mopidy.conf
-rw-r----- 1 mopidy root 277 Jan  2  2017 /etc/mopidy/mopidy.conf