Mopidy compatibility


#1

Hi all,

Sorry for the noob question but I’ve searched an answer for a simple question without luck:

Can I install mopidy on a pi 3 running Raspian stretch?

I mean non a Pi musicbox but mopidy as a normal app.

Thank you in advance!


#2

Yes. The page at https://docs.mopidy.com/en/latest/installation/raspberrypi/#how-to-for-raspbian-jessie is a little outdated but works on stretch just the same.


#3

Mopidy runs on all versions of Raspberry Pi. However, note that Raspberry Pi 2 B’s CPU is approximately six times as powerful as Raspberry Pi 1 and Raspberry Pi Zero, so Mopidy will be more joyful to use on a Raspberry Pi 2.

Pi3 is not quoted

You sure?


#4

I can confirm it - running with stretch on pi3. Just follow the docs as kingosticks said.


#5

Ok. It works!

But it doesn’t start.

I changes also port as suggested elsewhere but nothing changes happened.


#6

I don’t know what you mean by changing the port but you shouldn’t need to do that so please revert that change.

You’ll need to be a lot more specific about what exactly you are doing and what exactly you expect to happen.


#7

Hello,

sorry for the confusion.

Here’s a summary

I installed mopidy for my Pi3 using the tutorial linked above but when I tried to connect to it I received an error (connection refused)

Searching around I’ve found that may depend when running different istances of mopidy.

So I tried to change the port from 6600 to 6601 and from 6680 to 6681 to solve it but nothing happens.

Running mopidy config I noticed that the service is still on port 6600 (also if the file is changed), so I was wondering where is the problem now.

Thank you in advance!


#8

I’m going to assume you are trying to connect with an MPD client. One typical thing people run into is that they do not set the MPD hostname config setting to something which allows them to connect from a different machine to the one they installed Mopidy on; as per the warning at https://docs.mopidy.com/en/latest/ext/mpd/. If that sounds like you then you’ll want to have the following in your config file:

[mpd]
hostname = ::

Are you trying to run multiple instances of Mopidy on the same machine? You did not mention this before. If you are then you do need to make sure each Mopidy instance is configured to use a different port as multiple processes cannot bind to the same port. How exactly are you telling each instance of Mopidy to use a different port? You need to be more specific particularly since this is an atypical setup.


#9

Thank you for your suggestions!

Now it works!

The problem was related to host address and not to instances.
Thank you!

Last thing: where I can suggest to update the page to explicit the docs for raspberry pi 3 support?


#10

Super. You could open an issue at https://github.com/mopidy/mopidy/issues or you could submit some actual changes of https://github.com/mopidy/mopidy/blob/master/docs/installation/raspberrypi.rst for review.