Problems installing/running mopidy 2.0 on RPI

I was previously running mopidy 0.19.5 on my RPi (model B + hifiberry DAC), primarily to listen to Spotify. I could connect via http (Mopidy-MusicBox-Webclient) and also via mpd using mpod on my ipod. All was ok until I managed to trash my SD card.
So, by following instructions on mopidy website I’ve done a fresh installation of:

Two problems:

  1. I can’t connect via the ipod
  2. I can’t connect via the web interface

This is what I get when I run: mopidy config:
pi@raspberrypi:~/.config/mopidy $ mopidy config
cache_dir = $XDG_CACHE_DIR/mopidy
config_dir = $XDG_CONFIG_DIR/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000

color = true
console_format = %(levelname)-8s %(message)s
debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n %(message)s
debug_file = mopidy.log
config_file =

mixer = software
mixer_volume = 70
output = autoaudiosink
buffer_time =

scheme =
hostname =
port =
username =
password =

enabled = true
musicbox = false
websocket_host =
websocket_port =

enabled = true
username = RobertF555
password = ********
bitrate = 320
volume_normalization = true
private_session = false
timeout = 10
allow_cache = true
allow_network = true
allow_playlists = true
search_album_count = 20
search_artist_count = 10
search_track_count = 50
toplist_countries =

enabled = true
hostname = ::
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist =
default_playlist_scheme = m3u

enabled = true
hostname = ::
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname

enabled = true
protocols =
metadata_blacklist =
timeout = 5000

enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir =

enabled = true

enabled = true
media_dirs =
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

enabled = true
library = json
media_dir = /var/lib/mopidy/media
scan_timeout = 1000
scan_flush_threshold = 100
scan_follow_symlinks = false
excluded_file_extensions =

I also have a debug log when I run: mopidy --save-debug-log.
However that is 3,000 lines so I don’t think I should post all that.

Any help would be very welcome.

Thanks in advance and sorry for being so hopeless,


Perhaps you could paste the first few hundred lines of running just mopidy at ? Any config errors will be output without needing full debug logging enabled.

Maybe also if you were more exact on what you did and how. So, you had pimusicbox first and then setup this new setup on the same hardware? Did the address change, maybe, different ip different hostname? Maybe you are not connecting to hostname:6680/mopidy with the browser? Did you run mopidy as a service?

The log from running just mopidy is at:

In response to tot_rispekt:

  • Its the same hardware ie RPi B and hifiberry DAC
  • When I trashed the SD card running 0.19.5, I re-formatted it using the hifiberry installer and I chose Raspbian Jessie Lite then hifiberry DAC.
  • I then followed the installation instructions on the mopidy docs website. All seemed to go ok.
  • The RPi kept the same IP address of
  • With 0.19.5 I used to run mopidy as a service. At present I’m not running as a service because I thought it best to get things working before switching to running as a service.


The log says that mopidy is started and so is the web server. However, then it reports failed connections from an ip (you maybe trying to control it from anther computer). Maybe a firewall is blocking the connection?

Firstly thanks for the help so far.

I’m running win 7 with the built in firewall set to default settings.

musicbox_webclient is working ok. In fact it probably always was. The bit I hadn’t acknowledged is that it takes about 30 seconds for the mpd and HTTP servers to report that they’re running.
It then takes another couple of minutes for my spotify playlist to appear in the musicbox Playlists tab.

With that now working, I’ve switched to mopidy running as a service.

However, I still can’t get mPod fully working with my iPod. It won’t display my spotify playlist. I believe that mPod can talk to mopidy because I can pause and skip whatever is currently playing - which was setup via musicBox on my PC.

The mopidy [mpd] settings are:
enabled = true
hostname = ::
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist =
default_playlist_scheme = m3u

The mpod connection settings are:
Connection mode: Remote
Server: (IP address of the RPi)
Port: 6600
Use local cache: No (as per mpod Help. I’ve tried ‘Yes’ but it makes no difference.