Many streaming radio stations not working

On a new install a number of streaming radio stations don’t work.
Have tried same stations from Tunein and have entered URL directly.
example is
Same URL works on RhythmBox and on VLC player in Mate 16.04
Have downloaded latest and re-installed
Running Pi 2 with HiFiBerry Amp+

Not enough of a techo to pull this to bits, but it seems like a codec is missing?


PiMusicBox isn’t an active project anymore, the last release was over a year ago. There is a problem with the outdated mopidy version that it uses (0.19). I believe that the problem was fixed in 1.0 or 1.1. Anyway the new 2.0 version does not seem to have these problems. So you could either try that or if you want a ready made image so that you don’t have to anything else except flash an SD-card why not try Volumio ( There is a new version of it that either is already release or will be really soon (you can install and use it even though it is not oficially out, a sort of test version exists). It is very similar to pimusicbox, that is a custom mpd which you control over a node.js/angular/whatever website.

I tried on both Pi0 with usb sound card and Pi B+ through headphone socket both are basic setups and it plays fine I have only listened for 5 minutes on each, do the offending stations start at all? Can you play anything else?

Thanks guys,
I prefer the MusicBox WUI to Volumio, but may have to go there again - the WUI does not work well on my older version tablet.

Podcasts & music files are fine and I can play some but not all other stations. The offending stations don’t start … well with some of them I get a buzz or hum ???

Interesting though is that with Pi2 and MATE 16.04 it plays through RhythmBox & VLC but not through the RadioNZ streaming website & Firefox?

Playback on MATE is via HDMI, I am still trying to get the HiFiBerry HAT to work with MATE. Assuming I solve that, the problem with MATE is that I can only remote control via VNC which is a bit messy.

Is this an official announcement? It works for me as it is and it would be a shame to see it go.

I agree with you about the WUI on Volumio, for my set up, Musicbox does a fine job.
If you want to post the other station addresses I am happy to try them to try so we can find out if it’s the stream or setup.
I’m afraid you lost me a bit on the 2nd 2 paragraphs.

I have just tried Volumio - same problem. Adding the URL (the station is not on the Webradio listing and no joy … but the URL works on other players ??

have also tried KODI in ubuntu - URL works fine as does OSMC … so /

No, it’s not. The project will see further work when I find free time. I’m not happy with what I have achieved over the last year (very little) but that’s life.

a breakthrough (?). I have re-installed MATE 16.04 on the Pi2 to try and track down the different response of Firefox and RhythmBox to the URL.

Before RhythmBox would play the URL it needed to load GStreamer-plugins-ugly that ties in with my missing codec idea.

Now all I have to do is figure out how to get the gstreamer plugins into PiMusicBox (or if all else fails Volumio)

Well that’s a relief. As I say, for me and many others no doubt it works just fine. I want a music player and that’s exactly what it does. Thank you for spending time on it at all, and for taking time out to help me and others through this forum. If there is any easy task that you think somebody with limited knowledge could help with then please ask.

In my post I was not meaning to say that “PMB no longer exists” or something like that. I meant to point out that many of the packages and indeed the operating system that it is built on are “old” and even “end of life”. IIRC the way that streams and metadata are handled were changed in mopidy version 1.0. Because of this I know of several streams that can be played with VLC and rhythmbox et al. where as they do not play on PMB.

In retrospect, that hardly explains the problem here, however. Because I just installed PMB 0.6 in order to try this, and indeed the above given link (by the OP) does play!

Also, I don’t think that we should think that it is some ones “fault” that there has not been a new version after 0.6 or that everyone should change over to Volumio or other similar. I think that it is really nice that some people have volunteered their own time to make PMB. However, since PMB probably will not install on newer RPi’s without hacking and since there are problems in mopidy 0.19 that can only be rectified by hacking up a new install by hand, I think it is fair and polite to say to people that they should not wait around for the next release, but install something else for the time being and maybe check back later.

Yes, I agree that is probably for the best.

puzzled to say the least. I just installed PMB 0.6 in order to try this, and indeed the above given link (by the OP) does play!
PMB is a self contained operating system - can’t see why it did not play the URL for me. I have 0.6 and have also tried using the HiFiBerry installer.