Issues with Windows Share

Hey Guys -

I looked through similar posts before posting, but couldn’t find anything that helped. I built a MusicBox (v0.7.0RC7) this morning, but cannot get it to access the dedicated Windows share I created. Below is how I set it up followed by a couple of questions…

Windows Share

  • Standard folder with a couple of MP3s
  • Shared to everyone with full access
  • Created a dedicated (local) user with simple username/password
  • Windows 10 x64 1810
  • Tested access from 2 different networked systems successfully

MusicBox Settings


  1. Do I need to prefix the username with the server’s hostname + backslash? Something like “server\musicbox” This is required for some authentications. Tried with and without it without luck.
  2. I’m betting my issue lies with additional mount options, but hopefully someone can advise as I’m sure the options for Win10 would be known
  3. Unrelated, but is it possible to not only configure a file to start playing at startup, but have it loop indefinitely as well?

Thanks guys!


  1. No
  2. Yes. Very likely. I don’t have a Windows machine to test. I would guess you need to try increasing the vers mount option until it starts working.
  3. Yes. You can append additional mpc commands separated with a semicolon to the end of autoplay (similar to Can you set a Spotify autoplay URI to randomise song order?). For example:
autoplay = "local:track:MusicBox/Music%20File.mp3 ; mpc repeat on"

The startup script will then run:

mpc add local:track:MusicBox/Music%20File.mp3
mpc repeat on
mpc play

Appreciate the reply. I’ll give things a shot. Thanks!

Set the version to either 2 or 3
Add the windows domain / server hostname as a additional variable

You should be able to confirm the mount by running this from the command line:

mount -t cifs -o ro, user=username,password=password, domain=domain, vers=3.0 //path_to_windows_share /music/Network

Windows 10 has v1 disabled so you need to use version 2 or 3.

Also if the password has special chars it would be enclosed in single quotes when passed through and would result in a failed login. The could be modified to handle this:

FAIL => mount -t cifs -o ro, user=username,password=p@$$word, domain=domain, vers=3.0 //path_to_windows_share /music/Network

PASS => mount -t cifs -o ro, user=username,password=‘p@$$word’, domain=domain, vers=3.0 //path_to_windows_share /music/Network