Mopidy Discourse

Mopidy as a service - Doesn't load /etc/mopidy/mopidy.conf

Hello,

I installed Mopidy on a raspberry pi and it works. I can control it remotely with the musicbox client.

But I am confussed now:
It is said in the tutorial running as a system service that configurations can be done in /etc/mopidy/mopidy.conf.
But all my changes there have no effect on the service, because the service is made by user root.

Can I do it like:
[core] config_dir = /etc/mopidy ?
Or directly config_dir = /etc/mopidy/mopidy.conf

The documentation you have linked to is exactly right. The service is run as user mopidy and the config file /etc/mopidy/mopidy.conf is also owned by that user. Your normal pi user won’t have permission to view/edit it and so you should use a command such as sudo nano /etc/mopidy/mopidy.conf. Once you have made your changes you must restart the mopidy service (sudo service mopidy restart) and then you will see your changes take effect.

You can see exactly which config file is loaded in the mopidy log e.g.:

INFO [1165:MainThread] mopidy.config: Loading config from /etc/mopidy/mopidy.conf

And you can view the config that will be used with the command sudo mopidyctrl config.

Hej,

Thanks for your quick answer. It seems that the config file:
/usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf is loaded when I run sudo mopidyctl config.

I thought at a reboot the configuration would be done too.

So everytime I change anything I need to run mopidyctl config?

I also have another question:
Is mopidy secure when I did the normal raspberry security things like change passwords and ssh authentication?

Restart the Mopidy service after applying changes, or reboot.

The syntax here is that : is a separator so this is actually two config files: /usr/share/mopidy/conf.d and /etc/mopidy/mopidy.conf. You don’t need to worry about the first one.

Yes: rebooting your computer will restart the service. mopidyctl config is just a helpful way for you to see what config will be used when you next start the service, you do not need to run it. Mopidy will always load the config from the config file when it starts.

This should all 100% correlate with the document you linked to in your original post.

I don’t know what you mean with your last question.

No I made some experiments with the podcast extension.

I wrote to the etc/mopidy/mopidy.conf the following
feeds = http://www.npr.org/rss/podcast.php?id=510019 http://www.npr.org/rss/podcast.php?id=510253 http://www.npr.org/rss/podcast.php?id=510306 http://feeds.metaebene.me/lnp/mp3 http://logbuch-netzpolitik.de/feed/mp3

Everything else is as default.

I reboot the raspi and the feeds are not in Subscribed Feeds.

When I do the same as sudo -i and wrote the same lines in /root/.config/mopid/mopidy.conf and restart the raspi it works.

So the Mopidy service is configured with the root config. Can I change it anyhow?

can someone help me
i have everything filled in the config file but stil i get this

enabled = false  ; Extension disabled due to config errors.
username =   ; Must be set.
password =   ; Must be set.
client_id =   ; Must be set.
client_secret =   ; Must be set.

The way to configure Mopidy is outlined at Running — Mopidy 3.2.0-3-gb10f3115 documentation. Once you have read that page, please provide the info required to understand your problem as per Troubleshooting — Mopidy 3.2.0-3-gb10f3115 documentation. Then start a new topic and clearly describe your problem. Only then can someone help you.