/etc/mopidy/mopidy.conf not being read

I’ve just reinstalled my raspberry pi, and put on the latest version of raspbian and mopidy, and copied over my old /etc/mopidy/mopidy.conf file.

When I run mopidy, it doesn’t appear to be loading anything from /etc/mopidy/mopidy.conf
whether I run it as a service or a user.

It’s readable by everyone, and I’ve got rid of the conf.rc service specific config, same as I did in the last one.

When I run it, it says:

INFO     Loading config from: builtin defaults, /etc/xdg/mopidy/mopidy.conf, /home/pi/.config/mopidy/mopidy.conf, command line options

whereas I was expecting it to be asking for /etc/mopidy/mopidy.conf

Happens if I run it as root or as pi.

Any ideas what I’m doing wrong?

By default, Mopidy doesn’t look for config in /etc/mopidy/mopidy.conf. Though, if you use the Debian package and run Mopidy as a service or use the Debian package’s mopidyctl command, that config path will be used.

Balls, that makes sense, I was only running it as a user to check my conf was right, what an idiot.



The following command should do exactly what you want to:

sudo mopidyctl config