Modipy starts only with builtin defaults

i’ve installed mopidy on my PI and i have the problem, that it fully ignores my changes in the config file. It always just starts with the builtin defaults. Doesn’t matter if started as app or system service. Both config files in ~/.config/mopidy/mopidy.conf and /etc/mopidy/mopidy.conf are changed. I encounter the same problem on my ubuntu machine. I’ve also tried starting with --config configpath but it has no effect.
i found this thread but my configs should be readable.

ls -l /etc/modipy/modipy.conf

has this output:

-rwxr-xr-x 1 mopidy root 2027 Oct  5 11:35 /etc/mopidy/mopidy.conf

i am user “pi”. i don’t know what i can try anymore

Can I just check how you know it is ignoring the changes in your config file? Are you running mopidy config to make it display the active config or is it just not working as you expected?

well, both. mopidy config and sudo service mopidy run config both show default config. That means my spotify account settings and my changes in mpd section are ignored. There i changed the hostname to because i want to have acces from my desktop and this, of course, doesn’t work.

Did you install using pip or apt-get?

Installed it with apt-get. I am using raspbmc on my pi

Can you run

ps aux | grep mopidy

and post the output.


pi 7144 0.0 0.1 1980 616 pts/0 S+ 14:29 0:00 grep mopidy
mopidy 32628 0.0 4.7 85416 18108 ? Sl Oct05 0:03 /usr/bin/python /usr/bin/mopidy --quiet --config /etc/mopidy/extensions.d:/etc/mopidy/mopidy.conf

Have you checked the files in /etc/mopidy/extensions.d ?
There might be a spotify.conf with the default settings overriding your changes in /etc/mopidy/mopidy.conf.

there really is, but the documentation says that these are overwritten by the main config file. And the changes in mpd section are also not taken.
i recently found out that xbmc is not starting anymore. Google says mopidy and xbmc are using different versions of libtag which makes them incompatible. i think my plan using mopidy besides xbmc is cursed :wink:
i appreciate all your help, but i think this is a dead end

The last file path given to --config overrides the previous ones. /etc/mopidy/extensions.d is just defaults from the extension packages. All your own configuration should go in /etc/mopidy/mopidy.conf.

Running Mopidy alongside XBMC is doable. I’m personally running Mopidy on an xbian install. You can get around the libtag issue by following the hack/fix at