I have been unable to install Mopidy on Ubuntu 18.04 mainly because the two system installed python versions are python2.7 and python3.6. Therefore, by installing from apt.mopidy per the instructions this will result in the following error…
Mopidy requires >=python3.7 (found python3.6)
At this point I decided to start over and this time install python3.7 from source using alt-install method. I then utilized the built in tool
update-alternative to switch my python environment over to python3.7. This broke
apt as I predicted and I was still unable to get a successful installation of mopidy through pip.
Could someone provide some help please as I’m lost on what to do. It seems no matter what I try mopidy still points at python3.6.