Installing Mopidy 3 on KDE Neon (Ubuntu 18.04)

I’ve just installed the latest version of KDE Neon (User Edition 5.18), based on Ubuntu 18.04. I tried installing Mopidy (v3) using the Debian 10 repo as listed in the installation guide, but this doesn’t work:

$ sudo apt install mopidy
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) mopidy:amd64 < none -> 3.0.1-2 @rc puN Ib >
Broken mopidy:amd64 Depends on python3-pykka:amd64 < none | 2.0.2-3 @un uH >
  Considering python3-pykka:amd64 1 as a solution to mopidy:amd64 9999
    Reinst Failed early because of sphinx-rtd-theme-common:amd64
  Considering python3-pykka:amd64 1 as a solution to mopidy:amd64 9999
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mopidy : Depends: python3-pykka but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

It seems pretty harsh to only support Ubuntu 19.10, seeing as 18.04 is an LTS release. Furthermore, only Python 3.6.9 is provided in 18.04, and the pip-based installation of Mopidy requires 3.7.0!

I tried installing Mopidy 2 by editing the /etc/apt/sources.list.d/mopidy.conf file to use Jessie instead of Buster, but my other stuff (Mopidy Mobile, Mopidy-HTTP, etc.) doesn’t seem to like this.

Is there any simple way to install Mopidy 3 on 18.04?

I think the FAQ is still accurate with regards to 18.04

To be honest , I have not tried the 18.04 instructions since I wrote that guide. I can’t guarantee it all still works.

Thanks. That looks more complicated than I would like. I’ll stick with my Pi running Mopidy 3 for now and move the server over to KDE Neon once they release the next LTS based on 20.04.

I struggled with it for a bit - in the end I think there were fonts or other graphic elements required for Read The Docs that stymied me before I bowed to reality and upgraded Ubuntu to a later version.

Struggled with those specific instructions in the faq or your own method?

I’m sure it was my own method. I didn’t know the doc existed.

These steps worked for me in Ubuntu 18.04 with GNOME:

# deps: python3-pykka, sphinx-rtd-theme-common
sudo apt install fonts-lato fonts-roboto-slab libjs-modernizr
###sudo apt install sphinx-rtd-theme-common
wget httpLINK://ftp.debian.org/debian/pool/main/s/sphinx-rtd-theme/sphinx-rtd-theme-common_0.4.3+dfsg-1_all.deb
sudo dpkg -i sphinx-rtd-theme-common_0.4.3+dfsg-1_all.deb
sudo apt install python3-pykka
# install mopidy
wget -q -O - https://apt.mopidy.com/mopidy.gpg | sudo apt-key add -
sudo wget -q -O /etc/apt/sources.list.d/mopidy.list https://apt.mopidy.com/buster.list
sudo apt update
sudo apt install mopidy
# run as a service
sudo systemctl enable mopidy
# install python 3.7
sudo add-apt-repository ppa:deadsnakes/ppa
sudo apt install python3.7
# force Mopidy to use python3.7
sudo sed -i 's/python3/python3.7/' /usr/bin/mopidy
# install pygobject for GStreamer
sudo apt install libcairo2-dev libffi-dev libgirepository1.0-dev libglib2.0-dev python3.7-dev
sudo python3.7 -m pip install --ignore-installed --no-cache pygobject
# install GStreamer Python binding overrides
wget httpLINK://archive.ubuntu.com/ubuntu/pool/universe/g/gst-python1.0/python3-gst-1.0_1.16.1-1_amd64.deb
ar x python3-gst-1.0_1.16.1-1_amd64.deb
tar -pxvf data.tar.xz
sudo mv usr/lib/python3/dist-packages/gi/overrides/* /usr/local/lib/python3.7/dist-packages/gi/overrides/
# clean up
rm -rf usr debian-binary data.tar.xz control.tar.xz
sudo apt autoremove libcairo2-dev libffi-dev libgirepository1.0-dev libglib2.0-dev
1 Like

Please note the workaround (httpLINK -> htttp) for the new user 2-link-per-post limit. :confused: