How do i access the server

I have recently installed Mopidy and I dont know how I would get to the servers homepage on a web browser and my phone. What port do I need to forward?

Check your configuration using (sudo not needed depending on whether you installed as a service or not):

sudo mopidy config | grep port

If I remember correctly the default is 6680.

Another way, is to use a Zeroconf (aka Avahi) browser to discover the service.

I have made sure its on and that going into the ip and port wont give me any results. I have port forwarded it and it doesnt work on the mobile app either.
Also is this able to save positions in an audio file as I would like to put some audiobooks there

I don’t understand what port forwarding has to do with anything, please explain why that’s relevent.

More importantly, did you see the warning at Mopidy-HTTP — Mopidy 3.4.1-2-ge245adbc documentation ?

I cant turn it on.

It gets stuck there.

Also what stuff do I need to modify here? (only one image per post)

Just like the page I linked says, if you want to access the server from another device/computer/phone/toaster on your LAN, you need to change the hostname. Change it from

#hostname =


hostname = ::

That has removed the leading hash character (so it’s no longer a comment) and configures the http server to listen on all interfaces. You need to edit the correct config file that matches the way you run Mopidy. you can read the documentaton about that, I don’t want to reproduce any more of that here.

Your first screenshot shows Mopidy has started just fine. The server is running and ready for you to connect with a client.

I have uncommented hostname but I do get this when trying to start mopidy

root@lebnuc:~# mopidy
INFO 2023-02-04 19:56:03,131 [2027:MainThread] mopidy.main
Starting Mopidy 3.3.0
INFO 2023-02-04 19:56:03,157 [2027:MainThread] mopidy.config
Loading config from builtin defaults
INFO 2023-02-04 19:56:03,159 [2027:MainThread] mopidy.config
Loading config from file:///root/.config/mopidy/mopidy.conf
INFO 2023-02-04 19:56:03,160 [2027:MainThread] mopidy.config
Loading config from command line options
INFO 2023-02-04 19:56:03,264 [2027:MainThread] mopidy.main
Enabled extensions: file, stream, m3u, http, softwaremixer
INFO 2023-02-04 19:56:03,264 [2027:MainThread] mopidy.main
Disabled extensions: spotify
WARNING 2023-02-04 19:56:03,265 [2027:MainThread] mopidy.main
Found spotify configuration errors. The extension has been automatically disabled:
WARNING 2023-02-04 19:56:03,265 [2027:MainThread] mopidy.main
spotify/username must be set.
WARNING 2023-02-04 19:56:03,265 [2027:MainThread] mopidy.main
spotify/password must be set.
WARNING 2023-02-04 19:56:03,265 [2027:MainThread] mopidy.main
spotify/client_id must be set.
WARNING 2023-02-04 19:56:03,265 [2027:MainThread] mopidy.main
spotify/client_secret must be set.
WARNING 2023-02-04 19:56:03,265 [2027:MainThread] mopidy.main
Please fix the extension configuration errors or disable the extensions to silence these messages.
INFO 2023-02-04 19:56:03,371 [2027:MainThread] mopidy.commands
Starting Mopidy mixer: SoftwareMixer
INFO 2023-02-04 19:56:03,372 [2027:MainThread] mopidy.commands
Starting Mopidy audio
INFO 2023-02-04 19:56:03,374 [2027:MainThread] mopidy.commands
Starting Mopidy backends: FileBackend, M3UBackend, StreamBackend
INFO 2023-02-04 19:56:03,387 [2027:MainThread] mopidy.commands
Starting Mopidy core
INFO 2023-02-04 19:56:03,389 [2027:Audio-2 (_actor_loop)]
Audio output set to “autoaudiosink”
INFO 2023-02-04 19:56:03,396 [2027:MainThread] mopidy.commands
Starting Mopidy frontends: HttpFrontend
ERROR 2023-02-04 19:56:03,415 [2027:MainThread] mopidy.commands
Frontend (HttpFrontend) initialization error: HTTP server startup failed: [Errno 99] Cannot assign requested address
INFO 2023-02-04 19:56:03,417 [2027:MainThread] mopidy.commands
Starting GLib mainloop

Is anyone there?

Great. did you add the other character also? Presumably you did because that’s really clear in our docs, which you have since read. Do you have some other server already listening on port 6680?

I’m not sure how to tell if anything else is using that port but mabye changing it would work. Do you mean making the hostname line like
hostname = ::[ip]

No, it needs to be exactly like in the docs at


hostname = ::


hostname =

I have changed it to :: and the port to 6681 but im still getting the same thing.

You still get this error?

Frontend (HttpFrontend) initialization error: HTTP server startup failed: [Errno 99] Cannot assign requested address

no, Now its saying its running on that port, but when I go and open it up in my browser nothing happens

What was the stuff you did with port forwarding? Maybe that’s breaking it? Or are you running a firewall that’s blocking it?

Well I port forwarded the port. Im not sure if the firewall on my router is messing with it

It would be helpful if you could answer this.

Provide output of mopidy config and ifconfig and netstat -ltnup .

Are you in a container?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.