How can i prevent User & Password prompt on start up?

I have just installed Music Box on my Pi/ Noobs and it seems to be working (i cannot get Google Play Music to work, but can live without that for now).
Every time i start Music Box i get prompted for the default ‘login’ & ‘password’ values.
I have entered these, then rebooted a number of times and i keep getting asked for them
My intent is to run this directly through my amp/ speakers without a screen, so i need to remove this prompt and log in automatically, or disable the login altogether.
I’ve looked around, but I can’t find anyone else seeing this same problem.

Do you mean you are logging in via ssh or are you set up with the pi into a screen? I normally run it without a screen and do everything via the web page accessible on musicbox.local in which case you don’t log on. You can also access it via the web address 192.168.0.? You will need that from your browser

1 Like

I was able to set it up using a screen, and entered the default user/ pwd and get onto the dashboard via the browser (on Chromebook & on phone).
But when i tried to set it up directly onto my amp and without a screen, it just hung and every time i tried to log into it i got a message on my phone saying…

This site can’t be reached is unreachable.

And when i wired it back onto the TV, i get the prompts. This is what’s telling me that it’s a login issue.
Is there a way i can enter the user/ pwd remotely?

I tried musicbox.local just to be sure. But same result.

I assure you the local user login has absolutely nothing to do with Musicbox working or not. Are you moving the raspberry pi when connecting it to your amp? If so, are you certain the network connection is working at this location? Are you changing any other settings when connecting it to your amp, such as the audio option?

1 Like

OK… i tried it again and it just seems to be taking a lot longer than i’d have thought to load up.
I was only moving the Pi across the living room and not changing anything else.
It’s working now, but seems to be hanging from time to time. It may be because it’s closer to the amp, so i’ll try keeping them as far away as possible.
Thanks for the help.
Now all i need to figure out is ironing out the issue with my Google Play Music account. All credentials have been added to the settings file, but nothing comes up when i browse on Google Music.
But it’s all good. :slight_smile: