HDD not being scanned despite being mounted


#1

I gave up on trying to find my networked drive so I have plugged in the drive to the Pi directly. It is a 2TB WD USB-powered drive with its own power supply. Power supply is good (5v 3amp), test on other devices.

sudo blkid shows me

/dev/mmcblk0p1: SEC_TYPE=“msdos” LABEL=“MUSICBOX” UUID=“C522-EA52” TYPE=“vfat”
/dev/mmcblk0p2: UUID=“62ba9ec9-47d9-4421-aaee-71dd6c0f3707” TYPE=“ext4”
/dev/sda1: LABEL=“Music” UUID=“01D37B6FC0A0DB30” TYPE=“ntfs”

… so I am assuming the Pi can see my drive ok.

sudo fdisk -l gives me this:

Disk /dev/mmcblk0: 64.2 GB, 64222134272 bytes
4 heads, 16 sectors/track, 1959904 cylinders, total 125433856 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00014d34

_ Device Boot Start End Blocks Id System_
/dev/mmcblk0p1 8192 122879 57344 c W95 FAT32 (LBA)
/dev/mmcblk0p2 122880 125433855 62655488 83 Linux

Disk /dev/sda: 2000.4 GB, 2000365289472 bytes
255 heads, 63 sectors/track, 243197 cylinders, total 3906963456 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0916422b

_ Device Boot Start End Blocks Id System_
/dev/sda1 2048 3906961407 1953479680 7 HPFS/NTFS/exFAT

I then followed some instructions on the modmypi forum on how to auto mount the drive at start-up. My fstab file has the line:

/dev/sda1 /mnt ntfs defaults 0 0

I’m assuming I have done all this correctly and have rebooted the Pi. Musicbox is set to scan always at start-up but when I log into Musicbox (I’m using putty on Windows to log in and then using an Android phone to access via browser), no music is found. The hard drive light is not flashing, except at initial boot. It remains constantly on so is not being read.

Any pointers?

[Edit] For the record I have attached a USB stick (exfat) with one track on it and this is not being picked up either, even though the Pi can see it.


#2

Neither ntfs or exfat (puzzled why this unpopular format has been making a recent comeback) are support out of the box in the latest release.

Musicbox is configured to scan directories under /music so you need to mount your drive somewhere in there, not /mmt. The usbmount utility normally takes care of this but, as I said, it doesn’t support those formats in v0.7.0RC6.

I’ve made changes to fix this on github which you can see (and copy for yourself) at https://github.com/pimusicbox/pimusicbox/commit/1326a48b08353718ffd0e009a7aa445f26ddf5c0


#3

On April 15 you stated:

Your response here says:

Based on your earlier reply I reformatted to NTFS. From your responses I now understand you to say that ONLY ext4 will work with an external powered USB HDD. Is this correct?

As to why exFAT is being used please refer to this thread on reddit:

My conclusion so far is that external HDD will ONLY work if powered and formatted as ext4. Please confirm.

Thanks


#4

ext2, ext3, ext4 and fat32 are fully supported out of the box. Ntfs is technically supported but will not automatically mount like the aforementioned formats. Exfat is not supported. If you are willing to enter a few commands you can add full support for both ntfs and exfat to your system.


#5

I’d prefer to use NTFS as there is a 2gb limit on fat32 and I’ll be loading the music I’m ripping from my collect via a Windows machine. I do not use linux on any machine for reasons we don’t need to discuss. Can I resolve this issue without booting to a linux distro? If not, which distro? I don’t want it installed on the hard drive, so I have to use one that will boot from a usb drive. And, can you tell me what commands to enter? I appreciate your time. Thanks.


Won't see HD or USB stick
#6
  1. Enable SSH via websettings and reboot
  2. Download putty.exe from https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html
  3. Use putty to connect to your pimusicbox system via SSH (user = root, default password = musicbox)
  4. Run the following commands
    • apt-get update && apt-get install exfat-fuse
    • sed 's/hfsplus/hfsplus exfat ntfs/' -i /etc/usbmount/usbmount.conf
    • sed 's/sync,noexec/ro,noexec/' -i /etc/usbmount/usbmount.conf

#7

Thanks for this. I followed your commands and it worked! MusicBox can now see my NTFS hard drive!