"Error: timeout" when loading more than a handful of songs onto USB drive

I’ve got a musicbox set up on an OG pi. The goal is to make a player that has two buttons on it, one to play/pause, one to skip. When it starts up it starts playing songs on repeat, random, from the USB thumb drive. A tiny python script watches the gpio pins for button presses, and bobs your uncle. It’s entirely offline, just has power in and a headphone jack. It’s for my friends 90yo Grandma, super simple.

Except it doesn’t work.
I mean, it does work. If I put like 10 songs on there, it will play for days on end, without a hiccup. But when I put the 530 songs she wants on there, suddenly it can’t cope.

During startup, it says something like:
“Playing file:////
Error: Timeout”

Then it refuses to play, even manually. Exactly one time in my testing, did it actually start playing, but the song would play for a few seconds, then get garbled and stop m if I pressed the skip button it’d start again with a new song, only to do the same thing.

Things I’ve tried:
Putting all the files in the root directory of the USB drive.
Renaming all the files to get rid of giant filenames and special characters, now they are just sequential numbers.
Converting all of the flac files to mp3.
Checking files at random to make sure they are not corrupted.
Checking my python script to be sure it isn’t using excessive CPU, it is not.
Changing thumb drives from the 32gb, to a 4gb.

None of this has worked and I’m pulling my hair out. Any suggestions? Please?
Thank you

Can you provide the log which includes the exact error messages.

Sorry I should’ve started with that.

Here is the basic log, I’m working on the mopidy detailed log now.

GNU nano 2.2.6 File: musicbox_startup.log

Initializing MusicBox…

Setting sound configuration…
Probing sound devices:
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

  • Found internal device: card0
    HDMI output detected
  • Found internal device: card0
    HDMI output detected
    Selected card= (i2s= output=auto usb= intc=0)
    No output was specified/found, falling back to auto detection
    Selected card=0 (i2s= output=hdmi usb= intc=0)
    Using audio card0 (hdmi)
    MusicBox name is MusicBox
    Stopping Samba daemons: nmbd smbd.
    Starting Samba daemons: nmbd smbd.
    Create dss-key for dropbear…
    Will output 1024 bit dss secret key to ‘/etc/dropbear/dropbear_dss_host_key’
    Generating key, this may take a while…
    Public key portion is:
    ssh-dss AAAAB3NzaC1kc3MAAACBAKEiW0Qkwe5tgR6YOKQx68D/buFpmbMJgQiRB1F2uNNo1vZBweFSZnb$Fingerprint: md5 c2:3e:e1:a5:6b:f2:5d:69:c6:f7:49:62:94:11:0a:ed
    Create rsa-key for dropbear…
    Will output 1024 bit rsa secret key to ‘/etc/dropbear/dropbear_rsa_host_key’
    Generating key, this may take a while…
    Public key portion is:
    ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAAAgwCMfFUDDyqdqvUpjO2vH/RB7m+jb1KqWb5xG6ruMfbsyJd$Fingerprint: md5 b3:de:cd:5b:9b:84:ee:e3:55:fe:81:4b:18:bd:3c:4f
    Starting Dropbear SSH server: dropbear.
    Starting daemon monitor: monit.
    Scanning music-files, please wait…
    /usr/local/lib/python2.7/dist-packages/mopidy/ext.py:201: PkgResourcesDeprecationWa$ extension_class = entry_point.load(require=False)
    INFO Starting Mopidy 1.1.2
    INFO Loading config from builtin defaults
    INFO Loading config from /etc/mopidy/mopidy.conf
    INFO Loading config from command line options
    WARNING Failed local:track:USB/System%20Volume%20Information/IndexerVolumeGuid: Co$WARNING Failed local:track:USB/System%20Volume%20Information/WPSettings.dat: Could$WARNING Failed local:track:USB2/System%20Volume%20Information/IndexerVolumeGuid: C$WARNING Failed local:track:USB2/System%20Volume%20Information/WPSettings.dat: Coul$***********************************************************************************
    My IP address is
    Connect to me in your browser at http://MusicBox.local or

Waiting for Mopidy to accept connections…
OK MPD 0.19.0
Mopidy startup complete, playing file:///
error: Timeout
volume: 85% repeat: off random: on single: off consume: off
volume: 85% repeat: on random: on single: off consume: off
volume: 85% repeat: on random: on single: off consume: off

here is the full debug log