Configuring Mopidy

As a newbie on Linux I need help to configure mopidy. I have a SBC (Freedombox Pioneer) with Debian/Freedombox and I think that I was able to successfully install mopidy. I have an external soundcard pluged into the usb-port. But despite all the reading I wasn’t able to configure mopidy. The issue is, that I can’t reach the webinterface. Here is the output of mopidy config:

cache_dir = $XDG_CACHE_DIR/mopidy
config_dir = $XDG_CONFIG_DIR/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000
restore_state = false

verbosity = 0
format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n  %(message)s
color = true
config_file = 

mixer = software
mixer_volume = 
output = autoaudiosink
buffer_time = 

scheme = 
hostname = 
port = 
username = 
password = 

enabled = true
media_dirs = 
excluded_file_extensions = 
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

enabled = true
hostname =
port = 6680
zeroconf = Mopidy HTTP server on $hostname
allowed_origins = 
csrf_protection = true
default_app = mopidy

enabled = true
base_dir = 
default_encoding = latin-1
default_extension = .m3u8
playlists_dir = 

enabled = true

enabled = true
protocols = 
metadata_blacklist = 
timeout = 5000

enabled = true
card = 0
control = Master
min_volume = 0
max_volume = 100
volume_scale = cubic

enabled = true
hostname =
port = 6600
password = 
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist = 
default_playlist_scheme = m3u

My server runs on But I was not able to adjust the configuration file.
When I start mopidy in the terminal I receive this output:

INFO     2024-05-15 17:43:45,483 [23061:MainThread] mopidy.__main__
  Starting Mopidy 3.4.1
INFO     2024-05-15 17:43:45,612 [23061:MainThread] mopidy.config
  Loading config from builtin defaults
INFO     2024-05-15 17:43:45,624 [23061:MainThread] mopidy.config
  Loading config from file:///home/FBHS2/.config/mopidy/mopidy.conf
INFO     2024-05-15 17:43:45,628 [23061:MainThread] mopidy.config
  Loading config from command line options
INFO     2024-05-15 17:43:46,865 [23061:MainThread] mopidy.__main__
  Enabled extensions: stream, http, alsamixer, file, m3u, mpd, softwaremixer
INFO     2024-05-15 17:43:46,866 [23061:MainThread] mopidy.__main__
  Disabled extensions: none
INFO     2024-05-15 17:43:48,073 [23061:MainThread] mopidy.commands
  Starting Mopidy mixer: SoftwareMixer
INFO     2024-05-15 17:43:48,090 [23061:MainThread] mopidy.commands
  Starting Mopidy audio
INFO     2024-05-15 17:43:48,112 [23061:MainThread] mopidy.commands
  Starting Mopidy backends: FileBackend, M3UBackend, StreamBackend
INFO     2024-05-15 17:43:48,233 [23061:MainThread] mopidy.commands
  Starting Mopidy core
INFO     2024-05-15 17:43:48,244 [23061:Audio-2 (_actor_loop)]
  Audio output set to "autoaudiosink"
INFO     2024-05-15 17:43:48,331 [23061:MainThread] mopidy.commands
  Starting Mopidy frontends: HttpFrontend, MpdFrontend
INFO     2024-05-15 17:43:48,347 [23061:HttpFrontend-8 (_actor_loop)]
  HTTP server running at [::ffff:]:6680
INFO     2024-05-15 17:43:48,352 [23061:MainThread]
  MPD server running at [::ffff:]:6600
INFO     2024-05-15 17:43:48,365 [23061:MainThread] mopidy.commands
  Starting GLib mainloop

Does anybody have the nerves to help and guide me through the configuration?

kind regards

Take a look at Can't access Mopidy through localhost

Thank you @kingosticks! I did try these steps, but still get an error.
I have changed the configuration to hostname = and when I go to in the browser the address is not accessible (the server is well reachable).
Starting mopidy in the terminal gives me this information:
HTTP server running at [::ffff:]:6680
What am I doing wrong? Many thanks in advance!

The firewall didn’t let me on the system. I disabled the firewall and am now able to reach the server :slight_smile:

Thanks for the update. I’m not familiar with that distribution