Mopidy Discourse

Please Help me to configure mopidy

Hi, I have been trying to install mopidy with an Iris web interface for some time now.
I wanted to use mopidy to play my songs from nas, spotify on the phone when I’m away from home. This is my mopidy setup:
[core]
cache_dir = $XDG_CACHE_DIR/mopidy
config_dir = $XDG_CONFIG_DIR/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
#verbosity = 0
#format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n  $
#color = true
#config_file =

[audio]
mixer = software
mixer_volume =
output = autoaudiosink
buffer_time =

[proxy]
#scheme = 
#hostname = 
#port = 
#username = 
#password = 

[file]
enabled = true
media_dirs = /media/pi/NAS/Salvatore/1
#  $XDG_MUSIC_DIR|Music
#  ~/|Home
#excluded_file_extensions = 
#  .directory
#  .html
#  .jpeg
#  .jpg
#  .log
#  .nfo
#  .pdf
#  .png
#  .txt
#  .zip
#show_dotfiles = false
#follow_symlinks = false
metadata_timeout = 1000

[http]
enabled = true
hostname = ::
port = 5809
zeroconf = Mopidy HTTP server on $hostname
allowed_origins =
csrf_protection = true
static_dir = /opt/webclient/Iris
#default_app = iris

[m3u]
enabled = true
#base_dir = $XDG_MUSIC_DIR
#default_encoding = latin-1
#default_extension = .m3u8
#playlists_dir =

[softwaremixer]
enabled = true

[stream]
enabled = true
#base_dir = $XDG_MUSIC_DIR
#default_encoding = latin-1
#default_extension = .m3u8
#playlists_dir =

[softwaremixer]
enabled = true

[stream]
enabled = true
protocols =
  http
  https
#  mms
#  rtmp
#  rtmps
#  rtsp
#metadata_blacklist = 
timeout = 5000

[spotify]
client_id = myclient
client_secret = myclient

[youtube]
enabled = true
#youtube_api_key = 
#threads_max = 16
#search_results = 15
#playlist_max_videos = 20#api_enabled = false
#autoplay_enabled = false
#strict_autoplay = false
#max_autoplay_length = 600
#max_degrees_of_separation = 3

[soundcloud]
enabled = true
#explore_songs = 25
auth_token = mytoken

[local]
enabled = true
max_search_results = 100000
#media_dir = $XDG_MUSIC_DIR
#scan_timeout = 1000
#scan_flush_threshold = 100
#scan_follow_symlinks = false
#included_file_extensions = 
#excluded_file_extensions = 
#  .cue
#  .directory
#  .html
#  .jpeg
#  .jpg
#  .log
#  .nfo
#  .pdf
#  .png
#  .txt
#  .zip
#directories = 
#  Albums                  local:directory?type=album
#  Artists                 local:directory?type=artist
#  Composers               local:directory?type=artist&role=composer
#  Genres                  local:directory?type=genre
#  Performers              local:directory?type=artist&role=performer
#  Release Years           local:directory?type=date&format=%25Y
#  Tracks                  local:directory?type=track
#  Last Week's Updates     local:directory?max-age=604800
#  Last Month's Updates    local:directory?max-age=2592000
#timeout = 10
#use_artist_sortname = false
[iris]
enabled = true
country = IT
locale = it_IT


[headless]
enabled = true
device = ;needs to be set
enable_numbers = true
volume_up =
  KEY_VOLUMEUP
volume_down =
  KEY_VOLUMEDOWN
next_song =
KEY_RIGHT
  KEY_NEXTSONG
previous_song =
  KEY_PREVIOUSSONG
  KEY_LEFT
next_playlist =
  KEY_CHANNELDOWN
  KEY_DOWN
previous_playlist =
  KEY_CHANNELUP
KEY_UP
play =
  KEY_PLAY
pause =
  KEY_PAUSE
playpause =
  KEY_ENTER
mute =
  KEY_MUTE
shuffle =

[mpd]
enabled = false

I also installed Iris and I can also reach it but it doesn’t work, mopidy is perfectly working but it is as if it does not see Iris.

Please help me

Are you running Mopidy as a service? Have you got the config file in the correct place?

Also define “doesn’t work”. This is too vague. What do you expect to happen? If you expect to hear audio through your web browser you are going to be disappointed because that is not supported by Mopidy.

the config file is in the right place and i start it as a service.
It doesn’t work because when I connect to mopidy via http: // raspip: 5809 (I changed the port for convenience) the classic white mopidy screen reaches (https://images.app.goo.gl/Arf4HVWcKbzr9jzYA) me while if I add / iris reaches the home of iris with the vertical bar at the side but I have no possibility to click anything and I have no information in the center of the page.

Remove this. Don’t your logs show this as a config error?

Where has this config file come from? The core section is all wrong for using with the service. The Mopidy service does not ship with a config file like this, looks like you’ve tried to copy a user config. Delete all of this. Start over with a blank config file and add just the specific bits you need to customise.

The configuration file I initially posted was the one you use to use mopidy not as a Service, and I copied it to the / etc / mopidy folder.
I tried to create a config file with just the specific bits I need but nothing I can’t even reach mopidy

As I hopefully explained, the two config files (specifically the core section) are not compatible between running as your user and as a service. The general rule with Mopidy config files is that you should only define the config parts you need. Everything else in there is a distraction that makes mistakes harder to spot. It also makes upgrades harder as you get more chance of errors due to changes in our config (such as static_dir).

Did you set the http hostname config setting? Use sudo mopidyctl config to display the effective config and share that. Also look in the log for errors. You can find this, and other troubleshooting tips at Troubleshooting — Mopidy 3.1.1 documentation