Web clients addons dont appear

Hello everybody!

New mopidy user, trying to connect it to my Airsonic instance:

At the moment, i tried to install many web addons but non shows :-/
tried to install the with
pip install
sudo pip install
sudo -u mopidy pip install

Mopidyctl shows and no addons seems to be installed

here’s my config file:
cache_dir = $XDG_CACHE_DIR/mopidy
config_dir = $XDG_CONFIG_DIR/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000
restore_state = false

color = true
console_format = %(levelname)-8s %(message)s
debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n %(message)s
debug_file = mopidy.log
config_file =

mixer = software
mixer_volume =
output = autoaudiosink
buffer_time =

scheme =
hostname =
port =
username =
password =

enabled = true
hostname = ::
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist =
default_playlist_scheme = m3u

enabled = true
hostname = ::
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname
allowed_origins =
csrf_protection = true

enabled = true
protocols =
metadata_blacklist =
timeout = 5000

enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir =

enabled = true

enabled = true
media_dirs =
excluded_file_extensions =
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

enabled = false ; Extension disabled due to config errors.
library = json
media_dir = ; Must be set.
scan_timeout = 1000
scan_flush_threshold = 100
scan_follow_symlinks = false
excluded_file_extensions =

enabled = true
musicbox = false
websocket_host =
websocket_port =
on_track_click = PLAY_ALL

What am i doing wrong?

Regards - JS

Since you are running a service, you need to install the extensions globally (sudo). And since Mopidy 3+ is a Python 3 program, you also need to be installing them under Python 3. This will be something like:

sudo python3 -m pip install <SOME EXTENSION>

Our Extension Registry includes installation commands. And extensions should be specifying install commands like that in their README but I can believe that might not be correct everywhere.

Thanks for your help:

I’ve installed the subidy-mopidy plugin this way but i’m facing the same:

Plugin shows when runing as user but not as service:

how may i get around this?

here’s the mopidyctl:

everything looks to be installed:
pi@mopidy:/var/lib/mopidy/.local/lib/python3.7/site-packages $ ls
libsonic Mopidy_Subidy-1.0.0.dist-info Pykka-2.0.2.dist-info tornado
mopidy_subidy pykka py_sonic-0.7.7.dist-info tornado-6.0.4.dist-info

Edited config to load plugin but it’s not loading.

sorry to bother you but i don’t understand where to look at :slight_smile:
Regards JS

Why are those screenshots so different? The first one shows Mopidy 3 and Python 3 (correct), the second shows Mopidy 2 and Python 2 (old, not supported).

1 Like

I did a clean install and it looks to have used python 2 :-/

Will reinstall again i guess.
My bad.

EDIT: reinstalled correctly - PEBKAC - sorry!

Make sure you add apt.mopidy.com else you’ll get the old v2 version in the Debian repositories.

1 Like