Web clients dont appear


#1

Hi!

I have installed Modipy without any problem and put as a service. After installing several web clients they are not displayed in http://127.0.0.1:6680/mopidy
I installed it in a Raspberry 3 and im tested in the raspberry with Chrome.
Im installed web clients with:
pi@magicpiHost:/home $ sudo -u mopidy pip install Mopidy-Moped

My config file:
pi@magicpiHost:~ $ sudo mopidyctl config
Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf config” as user mopidy
[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
color = true
console_format = %(levelname)-8s %(message)s
debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n %(message)s
debug_file = /var/log/mopidy/mopidy-debug.log
config_file = /etc/mopidy/logging.conf

[audio]
mixer = software
mixer_volume =
output = autoaudiosink
buffer_time =

[proxy]
scheme =
hostname =
port =
username =
password =

[mpd]
enabled = true
hostname = 127.0.0.1
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist =
listall
listallinfo
default_playlist_scheme = m3u

[http]
enabled = true
hostname = 127.0.0.1
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname

[stream]
enabled = true
protocols =
http
https
mms
rtmp
rtmps
rtsp
metadata_blacklist =
timeout = 5000

[m3u]
enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir = /var/lib/mopidy/playlists

[softwaremixer]
enabled = true

[file]
enabled = true
media_dirs =
$XDG_MUSIC_DIR|Music
~/|Home
excluded_file_extensions =
.jpg
.jpeg
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[local]
enabled = true
library = json
media_dir = /home/pi/Music
scan_timeout = 1000
scan_flush_threshold = 100
scan_follow_symlinks = false
excluded_file_extensions =
.directory
.html
.jpeg
.jpg
.log
.nfo
.png
.txt
pi@magicpiHost:~ $

My log file:
2018-12-27 12:47:21,135 INFO [3749:MainThread] mopidy.config: Loading config from builtin defaults
2018-12-27 12:47:21,144 INFO [3749:MainThread] mopidy.config: Loading config from /etc/mopidy/mopidy.conf
2018-12-27 12:47:21,148 INFO [3749:MainThread] mopidy.config: Loading config from command line options
2018-12-27 12:47:21,282 INFO [3749:MainThread] mopidy.main: Enabled extensions: mpd, http, stream, m3u, softwaremixer, file, local
2018-12-27 12:47:21,282 INFO [3749:MainThread] mopidy.main: Disabled extensions: none
2018-12-27 12:50:35,305 INFO [3779:MainThread] mopidy.main: Starting Mopidy 2.1.0
2018-12-27 12:50:35,536 INFO [3779:MainThread] mopidy.config: Loading config from builtin defaults
2018-12-27 12:50:35,544 INFO [3779:MainThread] mopidy.config: Loading config from /etc/mopidy/mopidy.conf
2018-12-27 12:50:35,548 INFO [3779:MainThread] mopidy.config: Loading config from command line options
2018-12-27 12:50:35,682 INFO [3779:MainThread] mopidy.main: Enabled extensions: mpd, http, stream, m3u, softwaremixer, file, local
2018-12-27 12:50:35,683 INFO [3779:MainThread] mopidy.main: Disabled extensions: none
2018-12-27 12:50:36,201 INFO [3779:MainThread] mopidy.commands: Starting Mopidy mixer: SoftwareMixer
2018-12-27 12:50:36,208 INFO [3779:MainThread] mopidy.commands: Starting Mopidy audio
2018-12-27 12:50:36,214 INFO [3779:MainThread] mopidy.commands: Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend
2018-12-27 12:50:36,246 INFO [3779:Audio-2] mopidy.audio.actor: Audio output set to “autoaudiosink”
2018-12-27 12:50:36,307 INFO [3779:MainThread] mopidy.local.library: Loaded 12 local tracks using json
2018-12-27 12:50:36,319 INFO [3779:MainThread] mopidy.commands: Starting Mopidy core
2018-12-27 12:50:36,368 INFO [3779:MainThread] mopidy.commands: Starting Mopidy frontends: MpdFrontend, HttpFrontend
2018-12-27 12:50:36,373 INFO [3779:MainThread] mopidy.mpd.actor: MPD server running at [::ffff:127.0.0.1]:6600
2018-12-27 12:50:36,380 INFO [3779:HttpFrontend-10] mopidy.http.actor: HTTP server running at [::ffff:127.0.0.1]:6680
2018-12-27 12:50:36,381 INFO [3779:MainThread] mopidy.commands: Starting GLib mainloop
2018-12-27 12:50:41,558 INFO [3779:HttpServer] tornado.access: 304 GET /mopidy/ (127.0.0.1) 48.42ms
2018-12-27 12:50:41,640 INFO [3779:HttpServer] tornado.access: 304 GET /mopidy/mopidy.css (127.0.0.1) 29.65ms
2018-12-27 12:51:22,410 INFO [3779:HttpServer] tornado.access: 304 GET /mopidy/ (127.0.0.1) 5.27ms
2018-12-27 12:51:22,502 INFO [3779:HttpServer] tornado.access: 304 GET /mopidy/mopidy.css (127.0.0.1) 6.18ms
2018-12-27 12:51:26,199 INFO [3779:HttpServer] tornado.access: 304 GET /mopidy/ (127.0.0.1) 4.98ms
2018-12-27 12:51:26,312 INFO [3779:HttpServer] tornado.access: 304 GET /mopidy/mopidy.css (127.0.0.1) 8.67ms

Thanks for all!!


#2

I reach the web clients via the actual address of the Pi, for example 192.168.0.36:6680 or by the name hassbian.local:6680

From my /etc/mopidy/mopidy.conf file
[http]
enabled = true
hostname = 0.0.0.0
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname

more info here
Not sure if this is helpful or not, but might be worth a try.


#3

@Steve_Lambert is right, you need to set the hostname correctly as per the documentation link he has kindly provided. Thanks Steve.


#4

Thanks a lot, but i have the same problem. I modify the file /etc/mopidy/mopidy.conf to set the hostname to 0.0.0.0 and i reboot mopidy.
My mopidy conf:

pi@magicpiHost:~ $ sudo mopidyctl config
Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf config” as user mopidy
[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
color = true
console_format = %(levelname)-8s %(message)s
debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n %(message)s
debug_file = /var/log/mopidy/mopidy-debug.log
config_file = /etc/mopidy/logging.conf

[audio]
mixer = software
mixer_volume =
output = autoaudiosink
buffer_time =

[proxy]
scheme =
hostname =
port =
username =
password =

[mpd]
enabled = true
hostname = 127.0.0.1
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist =
listall
listallinfo
default_playlist_scheme = m3u

[http]
enabled = true
hostname = 0.0.0.0
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname

[stream]
enabled = true
protocols =
http
https
mms
rtmp
rtmps
rtsp
metadata_blacklist =
timeout = 5000

[m3u]
enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir = /var/lib/mopidy/playlists

[softwaremixer]
enabled = true

[file]
enabled = true
media_dirs =
$XDG_MUSIC_DIR|Music
~/|Home
excluded_file_extensions =
.jpg
.jpeg
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[local]
enabled = true
library = json
media_dir = /home/pi/Music
scan_timeout = 1000
scan_flush_threshold = 100
scan_follow_symlinks = false
excluded_file_extensions =
.directory
.html
.jpeg
.jpg
.log
.nfo
.png
.txt
pi@magicpiHost:~ $

Is there any way to check that web clients are installed correctly?
My capture screen:

Thanks for your replies


#5

sudo mopidyctl deps shows all the extensions that are found. Did you try installing with the extensions using sudo pip install? I’m not sure installing them as user mopidy will work.


#6

Yes perfect! The web clients are not installed correctly.
Thanks a lot!!!