Using WIFI does not work / Raspberry Pi 3 Model B Rev 1.2 / Reconfiguring network interfaces…RTNETLINK answers: No such process


#1

Hi,
latest RC is running on a Rasp 3. Cable Network works fine, but using the Wifi Network shows the message “ERR_CONNECTION_REFUSED” when loading the webpage.
Ping works fine on Wifi IP, Firewall is not enabled on device.
Any ideas?

Thanks in advance
Andre


#2

Hi there! Did I miss any information to put into within the last post? Or does no one has any idea to overcome this issue?
Please let me know.
Thank you
Andre


#3

Is it the onboard wifi? Can you provide the log at /var/log/musicbox_startup.log ?


#4

Hi! Yes it is the onboard wifi. I will upload the log-file tomorrow morning. Thanks in advance
Best regards,
Andre


#5

Ok. I figured out, as soon I configure the Wifi the cable LAN only get IPv6 addresses and Wifi did not get anything. The log file I did not upload yet, because of the several tests I did to get closer to the issue.
I will be back soon to deliver the log after doing the Wifi configurations.

best regards,
Andre


#6

So, are you trying to use WiFi and wired connections at the same time? Please do provide the log when you can.


#7

Hi Nick,
it took a while to find some free time to come back to this issue.
First some more information: I’m using a Raspberry Pi 3 Model B Rev 1.2
No further Hardware connected than an bluetooth device for keyboard and mouse. Onboard Sound and onboard WIFI.
Installation process was

  1. installing image, no configuration in settings.ini and network connected by wire.
    Result: everything works fine.
  2. Running Webinterface works fine too und now I put in the WIFI information within the network section. Saved the settings, reboot the system and unpluged the network cable.Means: switch the network, not having both connected.
  3. unfortunately the WIFI do NOT come up. My WIFI settings are WEP/WEP2 secured and the password does have 64 character. Any other Devices are working fine in wireless network and the Raspberry HW running Raspbian OS is also working fine with WIFI.
    Is it needed to reconfigure the network or to run a script if network has to be changed after first and initial boot?

Here are two log files:

  1. everythings seems to be working fine cable network connected:
    — start —

Initializing MusicBox…


Setting sound configuration…
Probing sound devices:

  • Found internal device: card0
    HDMI output detected
  • Found internal device: card0
    HDMI output detected
    Selected card= (i2s= output=auto usb= intc=0)
    No output was specified/found, falling back to auto detection
    Selected card=0 (i2s= output=hdmi usb= intc=0)
    Using audio card0 (hdmi)
    MusicBox name is MusicBox
    Stopping Samba daemons: nmbd smbd.
    Starting Samba daemons: nmbd failed!
    Starting Spotify Connect : librespot.
    Starting daemon monitor: monit.
    Scanning music-files, please wait…
    INFO Starting Mopidy 1.1.2
    INFO Loading config from builtin defaults
    INFO Loading config from /etc/mopidy/mopidy.conf
    INFO Loading config from command line options

My IP address is 192.168.66.32
Connect to me in your browser at http://MusicBox.local or http://192.168.66.32


— eof —
2) after switchin network (WIFI configured in settings.ini and disconnected wired network):
— start —


Initializing MusicBox…


Setting sound configuration…
Probing sound devices:

  • Found internal device: card0
    HDMI output detected
  • Found internal device: card0
    HDMI output detected
    Selected card= (i2s= output=auto usb= intc=0)
    No output was specified/found, falling back to auto detection
    Selected card=0 (i2s= output=hdmi usb= intc=0)
    Using audio card0 (hdmi)
    MusicBox name is MusicBox
    ifup: interface wlan0 already configured
    Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces … (warning).
    Reconfiguring network interfaces…RTNETLINK answers: No such process
    Internet Systems Consortium DHCP Client 4.2.2
    Copyright 2004-2011 Internet Systems Consortium.
    All rights reserved.
    For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/b8:27:eb:55:1f:89
Sending on LPF/eth0/b8:27:eb:55:1f:89
Sending on Socket/fallback
DHCPRELEASE on eth0 to 192.168.66.250 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
Reloading /etc/samba/smb.conf: smbd only.
done.
Stopping Samba daemons: nmbd smbd.
Starting Samba daemons: nmbd failed!
Waiting for network (1 of 4)…

Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces … (warning).
Reconfiguring network interfaces…done.
Waiting for network (2 of 4)…

Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces … (warning).
Reconfiguring network interfaces…done.
Waiting for network (3 of 4)…

Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces … (warning).
Reconfiguring network interfaces…done.
Waiting for network (4 of 4)…

Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces … (warning).
Reconfiguring network interfaces…done.


ERROR: Timeout waiting for network to start.
Check your network settings


Starting Spotify Connect : librespot.
Starting daemon monitor: monit.
Scanning music-files, please wait…
INFO Starting Mopidy 1.1.2
INFO Loading config from builtin defaults
INFO Loading config from /etc/mopidy/mopidy.conf
INFO Loading config from command line options
RTNETLINK answers: Network is unreachable

— eof —

Hope this helps to support me.
Very much thanks to you in advance

best regards,
Andre


#8

Hello Nick,

if you will get some time please find my update: https://discourse.mopidy.com/t/using-wifi-does-not-allow-to-display-webcontent/2444?u=andre_werner

best regards

Andre


#9

Hi there,

I’m sure this is a newbe issue by myself. Can anybody support?
Thanks to all of you.

Andre


#10

We support WPA/WPA2 wireless security. WEP is not secure and it’s unusual for someone to be using that, are you sure that’s what you have?

With WPA, you can either have a 64 hex digit (256-bit) pre-shared key or a 8-63 ASCII character passphrase that will be then converted into a 256-bit key. I don’t think WEP or WEP2 keys can be 64 characters long so it doesn’t make sense.


#11

Hello,
you are right. 63 ASCII characters are used for WPA/WPA2, but it’s still not working.
Config of Fritzbox 7490

What is ment with:

Reconfiguring network interfaces…RTNETLINK answers: No such process

in the log file. Is this the reason why it’s not working?

What to do in this situation?

Thanks in advance
Andre


#12

I’ve solved it by changing the SSID and password to have no whitespaces and removed the country code.


#13

Probably old and redundant but…
Had a bit of hair-tearing here myself in getting wifi going on a Pi.
What I found was that the SSID is case sensitive and the router wifi channel has to be 1 to 11 (mine had auto selected channel 13 so locking it down to a lower channel number made all the difference)


#14

Wifi channels 12 and 13 are Europe specific and you must set your country for the wifi hardware to use them. There is a section in the config file about this:

# Optionally set the wifi region for correct regulatory configuration (available channels etc.)
# Use the ISO / IEC 3166 alpha2 country code, e.g. wifi_country = GB
wifi_country =

I stopped using channel 13 at home after I had a couple of wifi things that didn’t support it at all.


#15

I spent a while trying to work this out when I was setting a Pi up a month or so back. The Raspberry Pi docs say (or said, at the time) that country was only needed for the Pi 3B+, but I my Pi Zero or Pi 2 wouldn’t connect without it.


#16

Just to clarify, it’s nothing to do with specific hardware and everything to do with local regulations. If the docs for certain models didn’t mention it then that’s an omission. It’s quite rare you end up on those channels unless you specifically choose them, so most people don’t realise the config consequences.


#17

Yeah, it specifically said in the docs “if you’re using a 3B+ you need to set country”. So I assumed I didn’t need to.