Update to mopidy 1.1, mopidy is not starting

Dear all,

my mopidy was runnging fine with 1.0.8. Yesterday arrive an update to 1.1
Now mopidy doesnt start.

with sudo service mopidy status I get the error:

WARNING  Failed expanding path ($XDG_MUSIC_DIR) fromfile/media_dirs config value.
11 07:38:43 musik mopidy[24629]: self.backends = Backends(backends)
Aug 11 07:38:43 musik mopidy[24629]: File "/usr/lib/python2.7/dist-packages/mopidy/core/actor.py", line 166, in __init__
Aug 11 07:38:43 musik mopidy[24629]: ) % (scheme, name(b), name(backends_by_scheme[scheme]))
Aug 11 07:38:43 musik mopidy[24629]: AssertionError: Cannot add URI scheme file for FileBackend, it is already handled by StreamBackend

What can I do?

mopidy is running on pi2 with jessie.
mpd, alsamixer, http, file, stream, mobile, podcast-gpodder, m3u,
simple-webclient, material-webclient, softwaremixer, moped, musicbox_webclient,
api_explorer, podcast, local, soundcloud

I hope you can helt me a litte bit.

Best regards,

file used to be one of the protocols handled by Mopidy-Stream, but we’ve changed the default stream/protocols configuration to not include file any more. You’ve probably set a bit more than you need in your configuration. You only need to set the configs that differs from the defaults.

To fix this remove the stream/protocols config from your mopidy.conf, or at the very least remove file from the stream/protocols config value.

We should probably add some code to stream to filter out the file uri scheme if file is enabled.

THX to all,

you made my day its working again!

Best regards,

I filed https://github.com/mopidy/mopidy/issues/1248 to track a better solution to this.