Need help getting mopidy set up on a server

I am setting up Mopidy on a DigitalOcean VPS. I can connect to it from the MPD client I am using (ncmpcpp), and I when I try to play music, the progress bar moves accordingly. However, no audio is produced.

I know this is a problem with Mopidy because it happens with every single client I have tried so far.

INFO Starting Mopidy 1.0.4 INFO Loading config from builtin defaults INFO Loading config from /root/.config/mopidy/mopidy.conf INFO Loading config from command line options INFO Enabled extensions: mpd, http, stream, m3u, softwaremixer, moped, soundcloud INFO Disabled extensions: local WARNING Found local configuration errors, the extension has been automatically disabled: WARNING local/media_dir must be set. WARNING Please fix the extension configuration errors or disable the extensions to silence these messages. INFO Starting Mopidy audio INFO Starting Mopidy backends: SoundCloudBackend, StreamBackend, M3UBackend INFO Audio output set to "autoaudiosink" INFO Loaded 0 M3U playlists from /root/.local/share/mopidy/m3u INFO Starting Mopidy core INFO Starting Mopidy frontends: MpdFrontend, HttpFrontend INFO MPD server running at [::ffff:]:6600 INFO HTTP server running at [::ffff:]:6680 INFO New MPD connection from [::ffff:]:44128
WARNING Element doesn't implement handling of this stream. Please file a bug.

The last warning appears when I try to play some music from the client.

Could someone help me out? The server is running on Ubuntu.

Unless you have explicitly set up some sort of streaming, the output audio will be on the same device that Mopidy is running. It sounds like you are expecting the audio to play on the local device you are running your MPD client on, that is not the general use case. See and for some workarounds until it’s better supported in Mopidy itself.