Spotify playlists not refreshing

Changes to the Spotify playlists are not synced on Mopidy. I have tried adding new playlists and deleted existing ones on the Spotify app itself, but neither of these changes show up on the Mopidy Android app that I’m using.

Only the playlists that were initially on Spotity when I installed Mopidy are there. Also any local playlists (non-Spotity) show up fine when I create them with either MPD or Mopidy

Strangely if I add tracks into a playlist from Spotify, they do show up in Mopidy within the playlist if that playlist is visible.

I’ve tried some suggested fixes from the internet, such as disabling the Spotity cache and removing the config directory, but none of them work. I’m just stuck with an initial Spotify playlist

I’m using the following versions running on a Raspberry Pi with Rasbian Jessie:
python-spotify 2.0.5
mopidy-spotify 3.0.0

Not sure if this is relevant but I do see some of these in the logs:

DEBUG 2016-09-19 23:37:57,390 [16582:Dummy-9] spotify.session
libspotify log message: 22:37:57.389 E [ap:4210] ChannelError(8, 1, playlist)
DEBUG 2016-09-19 23:37:57,391 [16582:Dummy-9] spotify.session
libspotify log message: 22:37:57.391 E [ap:4210] ChannelError(11, 1, playlist)
DEBUG 2016-09-19 23:37:57,392 [16582:Dummy-9] spotify.session
libspotify log message: 22:37:57.392 E [ap:4210] ChannelError(9, 1, playlist)

This works for me, as it’s always done. Normally when you add/remove a Spotify playlist you see something like the following in your debug log:

DEBUG    2016-09-20 13:52:08,359 [7066:SpotifyEventLoop] spotify.eventloop
  Notification received; processing events
DEBUG    2016-09-20 13:52:08,360 [7066:SpotifyEventLoop] spotify.session
  Notify main thread
DEBUG    2016-09-20 13:52:08,360 [7066:SpotifyEventLoop] spotify.playlist_container
  Playlist added at index 0
DEBUG    2016-09-20 13:52:08,360 [7066:SpotifyEventLoop] mopidy_spotify.playlists
  Spotify playlist "None" added to index 0
DEBUG    2016-09-20 13:52:08,360 [7066:SpotifyEventLoop] spotify.playlist_container
  Playlist container loaded
DEBUG    2016-09-20 13:52:08,360 [7066:SpotifyEventLoop] mopidy_spotify.playlists
  Spotify playlist container loaded
DEBUG    2016-09-20 13:52:08,360 [7066:SpotifyEventLoop] mopidy.listener
  Sending playlists_loaded to BackendListener: {}

It’s then up to your particular client to listen for the particular Mopidy event and update it’s UI.

Those channel errors do normally mean something went wrong at the Spotify end and could explain what you experience. However, if you were to restart Mopidy I would then expect it to pick up the new playlists, particularly if you’ve deleted the cache.

I’m experiencing this behavior since a while ago, stuck with the set of playlists I had at two or three months ago.

Spotify playlists seems to be out of sync between mopidy and the official client, that is, new playlists created on the official spotify client won’t show up in mopidy and viceversa. However, new tracks on old playlist do get refreshed.

The playlists showed in mopidy are consistent between mopidy restarts even if I delete the cache as suggested, calling playlists.refresh (), etc. I also get the ChannelError log lines.

I though this was due to the spotify deprecation of libspotify, as if they had copied at some point the playlists info to another place, and now there are two independent sets not updating each other. I do not claim this is the case, but it’s the ‘feeling’ I have from the current behavior.

Could someone please test if the playlists updating from official client to mopidy is still working in general? (Not necessarily at ‘real time’) Any tips on what could I look up on the logs to isolate the problem?


I can confirm that my playlists refresh in real time. Channel errors are never a good sign but they’ve always been temporary for me, to have this issue for so long is strange. And its odd that deleting the cache doesn’t leave you with no playlists at all. That suggets it’s something specific in the new playlists. You could try posting your full debug log, trace level logging might be useful (-vvvv option).

Spotify struggle to run one system, let alone two, so I doubt they are storing your new playlists somewhere else that’s inaccessible to libspotify.

Also, can you confirm which client you are using? Is it mopify?

Hi @kingosticks. I’m using a self made client which uses json-rpc so I can try and debug any calls allowed by the api.

The problem went away by deleting /var/lib/mopidy/spotify dir as suggested in I can’t see my Spotify playlists, as well as /var/cache/mopidy/spotify (which didn’t solve it on its own). After that I get again all of the playlists created on the official spotify client. I haven’t tried to create a new one since, though.

As for mopidy version, I’m using develop branch over raspbian. I haven’t followed the full discussion to see what the problem could have been on the first place, but I think that your answers there referred to PiMusicBox, right?