Smb connection error 112 host is down


#1

I am getting error 112 host is down when mopidy tries to connect to my smb share on a Synology rt2600’s usb attached drive - //SynologyRouter/usbshare1/mediafolder/music. I have 3 pi’s running osmc connected to that share, so I think that it is running and that I have the address entered correctly. I have tried embedding the address in quotes, using the ip address, and using a trailing / - to no avail. I can access the files via the router’s dlna service (if that helps at all). Any advice would be greatly appreciated.


File Syncing - from share to local
#2

There’s a fix for that. Login via ssh and run the following command

wget -O /opt/musicbox/startup.sh https://raw.githubusercontent.com/pimusicbox/pimusicbox/develop/filechanges/opt/musicbox/startup.sh

Then add the following new config setting under the existing mount settings in /boot/config/settings.ini.

mount_options = vers=1.0

1.0 should work but you may find you need to be use 2.0. Seems to depend on your SMB server.


No longer connecting to network share with 0.7.0RC6
Can't mount network drive
No longer connecting to network share with 0.7.0RC6
Problem to connect with Synology NAS
What address do I put in for my network drive?
#3

I was having the same issue while connecting to a windows home server 2011 share, and your instructions did solve it!
Thanks.


#4

well… shoot… that did resolve the error 112 issue, but now I’m getting a no such device or address error… you don’t have to specify port do you?


#5

Not that I know of. I really hate samba. Can you try running the mount command manually and append -vvv so it prints a more verbose error? I.e.

mount -t cifs -o ro,vers=1.0 //your/server/share /mount/network -vvv

#6

hrm…

root@MusicBox:~# mount -t cifs -o ro,vers=1.0 //SynologyRouter/usbshare1/mediafolder/music mount/network -vvv

mount: fstab path: “/etc/fstab”

mount: mtab path: “/etc/mtab”

mount: lock path: “/etc/mtab~”

mount: temp path: “/etc/mtab.tmp”

mount: UID: 0

mount: eUID: 0

mount: spec: “//SynologyRouter/usbshare1/mediafolder/music”

mount: node: “mount/network”

mount: types: “cifs”

mount: opts: “ro,vers=1.0”

mount: external mount: argv[0] = “/sbin/mount.cifs”

mount: external mount: argv[1] = “//SynologyRouter/usbshare1/mediafolder/music”

mount: external mount: argv[2] = “mount/network”

mount: external mount: argv[3] = “-v”

mount: external mount: argv[4] = “-o”

mount: external mount: argv[5] = “ro,vers=1.0”

Couldn’t chdir to mount/network: No such file or directory


#7

Sorry, wrong path

mount -t cifs -o ro,vers=1.0 //your/server/share /music/Network -vvv

#8

ok, and thanks a million for sticking with me on this…

root@MusicBox:/# mount -t cifs -o ro,vers=1.0 //SynologyRouter/usbshare1/mediafolder/music /music/Network -vvv

mount: fstab path: “/etc/fstab”

mount: mtab path: “/etc/mtab”

mount: lock path: “/etc/mtab~”

mount: temp path: “/etc/mtab.tmp”

mount: UID: 0

mount: eUID: 0

mount: spec: “//SynologyRouter/usbshare1/mediafolder/music”

mount: node: “/music/Network”

mount: types: “cifs”

mount: opts: “ro,vers=1.0”

mount: external mount: argv[0] = “/sbin/mount.cifs”

mount: external mount: argv[1] = “//SynologyRouter/usbshare1/mediafolder/music”

mount: external mount: argv[2] = “/music/Network”

mount: external mount: argv[3] = “-v”

mount: external mount: argv[4] = “-o”

mount: external mount: argv[5] = “ro,vers=1.0”

Password:

mount.cifs kernel mount options: ip=127.0.0.1,unc=\SynologyRouter\usbshare1,vers=1.0,user=root,prefixpath=mediafolder/music,pass=********

Retrying with upper case share name

mount.cifs kernel mount options: ip=127.0.0.1,unc=\SYNOLOGYROUTER\USBSHARE1,vers=1.0,user=root,prefixpath=MEDIAFOLDER/MUSIC,pass=********

mount error(6): No such device or address

Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)


#9

Running the same command on my test setup I see my server host (xps13) has been correctly resolved to it’s ip address (192.168.1.66). Yours seems to think it’s at 127.0.0.1 which is the local machine and I guess is maybe why the the unc value seems to be a local path (\blah instead of \\blah).

root@TestBox:~# mount -t cifs -o ro,vers=1.0 //xps13/Music/fish /music/Network -vvv
mount: fstab path: "/etc/fstab"
mount: mtab path:  "/etc/mtab"
mount: lock path:  "/etc/mtab~"
mount: temp path:  "/etc/mtab.tmp"
mount: UID:        0
mount: eUID:       0
mount: spec:  "//xps13/Music/fish"
mount: node:  "/music/Network"
mount: types: "cifs"
mount: opts:  "ro,vers=1.0"
mount: external mount: argv[0] = "/sbin/mount.cifs"
mount: external mount: argv[1] = "//xps13/Music/fish"
mount: external mount: argv[2] = "/music/Network"
mount: external mount: argv[3] = "-v"
mount: external mount: argv[4] = "-o"
mount: external mount: argv[5] = "ro,vers=1.0"
Password: 
mount.cifs kernel mount options: ip=192.168.1.66,unc=\\xps13\Music,vers=1.0,user=root,prefixpath=fish,pass=********

Some more info would be really useful.

apt-get update && apt-get install dnsutils smbclient
dig SYNOLOGYROUTER
nslookup SYNOLOGYROUTER
smbclient --list SYNOLOGYROUTER --no-pass

Can you just confirm if it still fails even when you specify the server IP address i.e.

mount -t cifs -o ro,vers=1.0,ip=IP_ADDRESS_OF_SYNOLOGYROUTER //SynologyRouter/usbshare1/mediafolder/music /music/Network -vvv

And regardless of the above success/failure, one last more thing to try if you don’t mind:

sed 's/name resolve order/;name resolve order/' /etc/samba/smb.conf -i
reboot

Then retry the normal mount command again when it comes back up:

mount -t cifs -o ro,vers=1.0 //SynologyRouter/usbshare1/mediafolder/music /music/Network -vvv

#10

sorry, had to trim the links out and repost to get into the forum

root@MusicBox:/# apt-get update && apt-get install dnsutils smbclient

Fetched 14.2 MB in 37s (381 kB/s)

Reading package lists… Done

Reading package lists… Done

Building dependency tree… Done

Suggested packages:

rblcheck

The following NEW packages will be installed:

dnsutils smbclient

0 upgraded, 2 newly installed, 0 to remove and 5 not upgraded.

Need to get 4778 kB of archives.

After this operation, 38.3 MB of additional disk space will be used.

2:3.6.6-6+deb7u15 [4615 kB]

1:9.8.4.dfsg.P1-6+nmu2+deb7u20 [163 kB]

Fetched 4778 kB in 2s (2024 kB/s)

Selecting previously unselected package smbclient.

(Reading database … 26046 files and directories currently installed.)

Unpacking smbclient (from …/smbclient_2%3a3.6.6-6+deb7u15_armhf.deb) …

Selecting previously unselected package dnsutils.

Unpacking dnsutils (from …/dnsutils_1%3a9.8.4.dfsg.P1-6+nmu2+deb7u20_armhf.deb) …

Setting up smbclient (2:3.6.6-6+deb7u15) …

Setting up dnsutils (1:9.8.4.dfsg.P1-6+nmu2+deb7u20) …

root@MusicBox:/# dig SYNOLOGYROUTER

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> SYNOLOGYROUTER

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62766

;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:

;SYNOLOGYROUTER. IN A

;; ANSWER SECTION:

SYNOLOGYROUTER. 0 IN A 127.0.0.1

;; Query time: 5 msec

;; SERVER: 192.168.1.1#53(192.168.1.1)

;; WHEN: Sat Mar 24 13:28:49 2018

;; MSG SIZE rcvd: 48

root@MusicBox:/# nslookup SYNOLOGYROUTER

Server: 192.168.1.1

Address: 192.168.1.1#53

Name: SYNOLOGYROUTER

Address: 127.0.0.1

root@MusicBox:/# smbclient --list SYNOLOGYROUTER --no-pass

WARNING: The security=share option is deprecated

session setup failed: NT_STATUS_ACCOUNT_DISABLED

root@MusicBox:/#

root@MusicBox:/# mount -t cifs -o ro,vers=1.0,ip=192.168.1.1 //SynologyRouter/usbshare1/mediafolder/music mount/network -vvv

mount: fstab path: “/etc/fstab”

mount: mtab path: “/etc/mtab”

mount: lock path: “/etc/mtab~”

mount: temp path: “/etc/mtab.tmp”

mount: UID: 0

mount: eUID: 0

mount: spec: “//SynologyRouter/usbshare1/mediafolder/music”

mount: node: “mount/network”

mount: types: “cifs”

mount: opts: “ro,vers=1.0,ip=192.168.1.1”

mount: external mount: argv[0] = “/sbin/mount.cifs”

mount: external mount: argv[1] = “//SynologyRouter/usbshare1/mediafolder/music”

mount: external mount: argv[2] = “mount/network”

mount: external mount: argv[3] = “-v”

mount: external mount: argv[4] = “-o”

mount: external mount: argv[5] = “ro,vers=1.0,ip=192.168.1.1”

Couldn’t chdir to mount/network: No such file or directory

last instruction and reboot (sorry, lost the copy when putty closed)

root@MusicBox:~# mount -t cifs -o ro,vers=1.0 //SynologyRouter/usbshare1/mediafolder/music /music/Network -vvv

mount: fstab path: “/etc/fstab”

mount: mtab path: “/etc/mtab”

mount: lock path: “/etc/mtab~”

mount: temp path: “/etc/mtab.tmp”

mount: UID: 0

mount: eUID: 0

mount: spec: “//SynologyRouter/usbshare1/mediafolder/music”

mount: node: “/music/Network”

mount: types: “cifs”

mount: opts: “ro,vers=1.0”

mount: external mount: argv[0] = “/sbin/mount.cifs”

mount: external mount: argv[1] = “//SynologyRouter/usbshare1/mediafolder/music”

mount: external mount: argv[2] = “/music/Network”

mount: external mount: argv[3] = “-v”

mount: external mount: argv[4] = “-o”

mount: external mount: argv[5] = “ro,vers=1.0”

Password:

mount.cifs kernel mount options: ip=127.0.0.1,unc=\SynologyRouter\usbshare1,ver s=1.0,user=root,prefixpath=mediafolder/music,pass=********


#11

So what exactly is synologyrouter? A synology nas or something else? What OS is it running? It’s odd that it returns 127.0.0.1 as the nslookup result but maybe that’s allowed and its up to the client to figure out that actually means 192.168.1.1. To me that seems a very odd thing to do but I’m no expert in this.

Did the last command succeed? The one before it is using the wrong path (should be /music/Network).


#12

It is a router, a Synology 2600ac, with a couple of attached usb drives. I think the command worked… I can rerun them and capture the output this time…


#13
root@MusicBox:/# dig SYNOLOGYROUTER

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> SYNOLOGYROUTER
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11700
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; QUESTION SECTION:
;SYNOLOGYROUTER.                        IN      A
;; ANSWER SECTION:
SYNOLOGYROUTER.         0       IN      A       127.0.0.1
;; Query time: 7 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Sun Mar 25 06:33:06 2018
;; MSG SIZE  rcvd: 48

root@MusicBox:/# nslookup SYNOLOGYROUTER

Server:         192.168.1.1
Address:        192.168.1.1#53
Name:   SYNOLOGYROUTER
Address: 127.0.0.1

root@MusicBox:/# smbclient --list SYNOLOGYROUTER --no-pass

WARNING: The security=share option is deprecated
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.6]
Sharename       Type      Comment
---------       ----      -------
IPC$            IPC       IPC Service (MusicBox (MusicBox))
Music           Disk      Directory for music files
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.6.6]
Server               Comment
---------            -------
MUSICBOX.LOCAL       MusicBox (MusicBox)
SYNOLOGYROUTER
TIMPC
Workgroup            Master
---------            -------
WORKGROUP            MUSICBOX.LOCAL

root@MusicBox:/# mount -t cifs -o ro,vers=1.0,ip=192.168.1.120 //SynologyRouter/usbshare1/mediafolder/music mount/network -vvv

mount: fstab path: "/etc/fstab"
mount: mtab path:  "/etc/mtab"
mount: lock path:  "/etc/mtab~"
mount: temp path:  "/etc/mtab.tmp"
mount: UID:        0
mount: eUID:       0
mount: spec:  "//SynologyRouter/usbshare1/mediafolder/music"
mount: node:  "mount/network"
mount: types: "cifs"
mount: opts:  "ro,vers=1.0,ip=192.168.1.120"
mount: external mount: argv[0] = "/sbin/mount.cifs"
mount: external mount: argv[1] = "//SynologyRouter/usbshare1/mediafolder/music"
mount: external mount: argv[2] = "mount/network"
mount: external mount: argv[3] = "-v"
mount: external mount: argv[4] = "-o"
mount: external mount: argv[5] = "ro,vers=1.0,ip=192.168.1.120"

Couldn't chdir to mount/network: No such file or directory

root@MusicBox:/# sed 's/name resolve order/;name resolve order/' /etc/samba/smb.conf -i

root@MusicBox:/#

#14

Please substitute mount/network for /music/Network. Only the mount command needs to be rerun.


#15

I found a load of Google results for synology owners struggling with their routers resolving their hostname to 127.0.0.1. I wouldn’t want my router doing that but if you don’t have problems with your other machines then it seems unfair for me to blame it on that.

It would be interesting to learn what mount command those osmc boxes are successfully using. Considering the above, I can’t see how they can be using the hostname. If you login to one of those and just run mount it’ll display the parameters.


#16

Thanks again so much for your help.

root@MusicBox:/# mount -t cifs -o ro,vers=1.0 //SynologyRouter/usbshare1/mediafolder/music /mount/network -vvv

mount: fstab path: "/etc/fstab"
mount: mtab path:  "/etc/mtab"
mount: lock path:  "/etc/mtab~"
mount: temp path:  "/etc/mtab.tmp"
mount: UID:        0
mount: eUID:       0
mount: spec:  "//SynologyRouter/usbshare1/mediafolder/music"
mount: node:  "/mount/network"
mount: types: "cifs"
mount: opts:  "ro,vers=1.0"
mount: external mount: argv[0] = "/sbin/mount.cifs"
mount: external mount: argv[1] = "//SynologyRouter/usbshare1/mediafolder/music"
mount: external mount: argv[2] = "/mount/network"
mount: external mount: argv[3] = "-v"
mount: external mount: argv[4] = "-o"
mount: external mount: argv[5] = "ro,vers=1.0"

Couldn't chdir to /mount/network: No such file or directory

so I tried it with Network too…

root@MusicBox:/# mount -t cifs -o ro,vers=1.0 //SynologyRouter/usbshare1/mediafolder/music /mount/Network -vvv

mount: fstab path: "/etc/fstab"
mount: mtab path:  "/etc/mtab"
mount: lock path:  "/etc/mtab~"
mount: temp path:  "/etc/mtab.tmp"
mount: UID:        0
mount: eUID:       0
mount: spec:  "//SynologyRouter/usbshare1/mediafolder/music"
mount: node:  "/mount/Network"
mount: types: "cifs"
mount: opts:  "ro,vers=1.0"
mount: external mount: argv[0] = "/sbin/mount.cifs"
mount: external mount: argv[1] = "//SynologyRouter/usbshare1/mediafolder/music"
mount: external mount: argv[2] = "/mount/Network"
mount: external mount: argv[3] = "-v"
mount: external mount: argv[4] = "-o"
mount: external mount: argv[5] = "ro,vers=1.0"

Couldn't chdir to /mount/Network: No such file or directory

#17

I ran mount on my old pi1 running osmc:

devtmpfs on /dev type devtmpfs (rw,relatime,size=175596k,nr_inodes=43899,mode=755)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /run type tmpfs (rw,relatime)
/dev/mmcblk0p2 on / type ext4 (rw,noatime,stripe=1024,data=ordered)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mmcblk0p1 on /boot type vfat (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=36124k,mode=700,uid=1000,gid=1000)

#18

You are still using the wrong path in many of those test commands above, it must be /music/Network, there should be no confusion with that part of the command. When you are getting that wrong you are getting the error message “No such file or directory”, which is not the “No such device or address” error we are try to chase down here. Please run the command below exactly:

 mount -t cifs -o ro,vers=1.0,ip=192.168.1.120 //SynologyRouter/usbshare1/mediafolder/music /music/Network -vvv

I would expect the above to work and I would also expect //192.168.1.120/usbshare1/mediafolder/music to work too. Looks like OSMC is using another method.


#19

ok… sorry about that.

root@MusicBox:/# mount -t cifs -o ro,vers=1.0,ip=192.168.1.120 //SynologyRouter/usbshare1/mediafolder/music /music/Network -vvv

mount: fstab path: “/etc/fstab”

mount: mtab path: “/etc/mtab”

mount: lock path: “/etc/mtab~”

mount: temp path: “/etc/mtab.tmp”

mount: UID: 0

mount: eUID: 0

mount: spec: “//SynologyRouter/usbshare1/mediafolder/music”

mount: node: “/music/Network”

mount: types: “cifs”

mount: opts: “ro,vers=1.0,ip=192.168.1.120”

mount: external mount: argv[0] = “/sbin/mount.cifs”

mount: external mount: argv[1] = “//SynologyRouter/usbshare1/mediafolder/music”

mount: external mount: argv[2] = “/music/Network”

mount: external mount: argv[3] = “-v”

mount: external mount: argv[4] = “-o”

mount: external mount: argv[5] = “ro,vers=1.0,ip=192.168.1.120”

ip address 192.168.1.120 override specified

Password:

mount.cifs kernel mount options: ip=192.168.1.120,unc=\SynologyRouter\usbshare1,vers=1.0,user=root,prefixpath=mediafolder/music,pass=********

Retrying with upper case share name

mount.cifs kernel mount options: ip=192.168.1.120,unc=\SYNOLOGYROUTER\USBSHARE1,vers=1.0,user=root,prefixpath=MEDIAFOLDER/MUSIC,pass=********

mount error(6): No such device or address

Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

root@MusicBox:/#


#20

ahhh! I copied one of your wrong commands without checking the rest of it - this is a comedy of errors by both parties! These latest commands are using the wrong IP address! We want to be using the IP for SynologyRouter which is apparently 192.168.1.1 (and not 192.168.1.120, where on earth did that originally come from??).

mount -t cifs -o ro,vers=1.0,ip=192.168.1.1 //SynologyRouter/usbshare1/mediafolder/music /music/Network -vvv