RPI3 with HiFiBerry Digi+ using Pi MusicBox gives no sound (Optical / toslink light off)

Hi all,

I am trying to use my Raspberry Pi 3B with HiFiBerry as Pi MusicBox 0.6

I cannot get sound from both the toslink and coaxial digital output.
The toslink does not transmit light but the green LED on top of HiFiBerry is on.

In order to get Pi Musicbox working on the RPi3 I did the following:

  1. Add [force_eeprom_read=0] to [config.txt]
  2. Replaced [.dtb] [.bin] [.dat] [.elf] files with those from [see link below]
    (this is version 1.20160315)

Furthermore I’ve tried the following solutions:

  1. Add [dtoverlay=pi3-disable-bt] to [config.txt]
  2. Replace [hifiberry-digi-overlay.dtb] from the [overlays] folder with those from above link

Odd behaviour (at least to me):

  1. When shutting down the green LED on the RPi-board flashes and at the tenth flash it stays on.
    At the same time the HifiBerry toslink starts transmitting light and stays on.
  2. It starts playing songs but after 10 seconds it starts at 0 again, looping and then the system becomes unresponding. (local file, mp3)

When I put the SD-card in my RPi2 (without reverting the settings/files, except [dtoverlay=pi3-disable-bt]) it works rightaway.

I am at the end of my current knowledge. Can you help me out with this?

This probably won’t be much help, but if you have a spare SD card, try to build up by getting Jessie, then installing and testing the Digi+, then Mopidy then Musicbox (in my case, then Snapcast). I’ve done it twice that way, once with a Pi2 and just last weekend with a Pi3. It took a day.

IMO there’s little use for the PiMusicBox image at this moment. A real Jedi could do it on Jessie Lite, but I get addicted to being able to browse for answers and cutting and pasting, so I used the full Jessie image then shrunk the video buffer and switched off booting into the GUI as my last step.

Going at it this way gives you lots of points to test the equipment along the way and newer versions of all of the underlying software. PiMusicBox hasn’t been updated for a fair while the last time I looked. I also got annoyed that I’d make a change to a configuration file, but PiMusicBox takes precautions and will copy the out-of-the-box files back over top of your changes.

I’m using DAC’s and DAC+'s, but the work should be largely the same and if you have spare SD card already all this is costing you is a little time. The very first time I used PiMusicBox, but the older versions of Mopidy and other pieces that it uses turned that into a proof of concept. I’m very happy with my system.

Good luck,


Hi KO,

Thanks a lot for your reply. It also did cost me about a day but I got it working as Mopidy.
I have been trying and in the end I am now working with the latest Mopidy with musicbox on the Pi3.
Musicbox crashed some times on my Pi2, this runs really smoothly.

With all the trial and error I have no need for the settings of musicbox anymore.
Also some playlist-bugs are gone which I really like :slight_smile:
I did use Jesse Lite as I do almost everything using SSH.

For anyone wanting to get this working. Please find some instructions below

1. You need to add this to the config.txt file while the MicroSD is in the cardreader:
Without it you will not get past the rainbow-screen

(the “dtoverlay=pi3-disable-bt” might not be necessary anymore)

2. Put the correct line for your hifiberry in the (same) config.txt-file
https://support.hifiberry.com/hc/en-us/articles/205377651-Configuring-Linux-4-x-or-higher (do not test sound)

3. Setup settings of linux
(Default username: pi, password: raspberry)
You cannot do this using a remote computer as SSH is not yet enabled
Enter “sudo raspi-config” from the command line
Expand the file system to fill the SD card.
Change the password of the pi user.
Change the time zone.
Under “Advanced Options”:
Set a hostname.
Enable SSH if not already enabled.

Once done, select “Finish” and restart your Pi.

4. Configure ALSA
https://support.hifiberry.com/hc/en-us/articles/205377651-Configuring-Linux-4-x-or-higher2 (second instruction)
Now restart your Pi (sudo reboot)

5. Test the sound with sox (second instruction on page)

6. Install Python by entering the following commands
(I couldn’t find the instructions I used but I think it were the following:)
sudo apt-get update
sudo apt-get install python-pip python-dev build-essential

7. Install Mopidy using below instructions
Include the add-ons you wish to use and don’t forget mopidy-musicbox-webclient

8. Configure Mopidy and it’s plugins
This took me some time and I do not know all the steps anymore. Below text needs to be in the configfile:

mixer = software
output = alsasink

For me it appeared to be difficult to find the location and modify the config file and get it running.
I forgot to note it down so it might have been a bit different:

  1. Start mopidy: sudo mopidy (might not work well with incorrect settings)
  2. Modify the settings file if needed ./root/.config/mopidy/mopidy.conf)
  3. When the setup is working, end mopidy (ctrl-c) and copy mopidy.conf to ./etc/mopidy/
  4. Let it start as a service at reboot using sudo systemctl enable mopidy
    (For testing it is the easiest to have web-services installed https://docs.mopidy.com/en/latest/ext/web/#ext-web)
    (Remember the default port is 6680 so you need to enter that on the webpage i.e. http://192.x.x.x:6680)

I hope I didn’t leave anything out. Enjoy the music!