MusicBox not playing via HifiBerry Digi


#1

Hi all,

Got a model B RaspberryPi running Musicbox (0.5.1), but I cannot get it to output via the HifiBerry Digi.
I am quite new with this, so looking for your input to determine the rootcause.

The config file is set to: output = hifiberry_digi
However it is still (and only) outputting via the analog output. From the manual I understand that setting the default output should override the automatic detection, but should setting it to i2S also disable the analog output?

On the HifiBerry Digi the green LED is lit, but the optical output is not lit. On the RCA there is also no audio output. (I tried two different hifiberry digi boards and triple checked the soldering of the header)

Previously I did not have any issues getting a Hifiberry DAC working, but ran out of ideas and knowledge to solve this problem.

Thanks for your help in prior!

Best regards,
Frank


#2

Same for me … after fresh install i have no sound via hifiberry digi.

aplay -l shows:
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0

If I change my /etc/asound.conf from card 0 to card 1 like:
pcm.!default {
type hw
card 1
}
ctl.!default {
type hw
card 1
}

everything is fine.

But /etc/asound.conf is overwritten after every reboot … how could I do this change permanently?


#3

I tried tilojandt’s solution and it works. However, he’s correct that asound.conf is reset on reboot. I’m using 0.5.2.

Any suggestions?


#4

Hack the setsound.sh file (or whatever it’s called, in /opt/musicbox) to
not overwrite your asound.conf file. Obviously this isn’t a practical fix
for musicbox but it’ll keep your system working in the meantime.


#5

Thanks kingosticks. That seems to fix it for now. Hopefully it will be sorted in 0.5.3. Or is it a problem for HiFiBerry? or Raspbian?


#6

I have the Same configuration with the Same problem.
I tried to modify the asound.conf like tilojandt did. But i get no sound out of it. Need i restart the sound Module or something else? If yes… What is the command?
ThX & Greets


#7

Yes you have to reload the Alsa configuration: alsa force-reload


#8

ThX, for the Tip. now its working very fine via optic cable. Is 44.1khz the maximum, or is there a way to set it higher?

Greets


#9

Hi, I jump in here. I am new to musicbox, and cannot get the hifiberry_digi soundcard working. My settings are as above. Until this point.

In several logfiles, there are errors showing up, but I do not know where to start.

In general, is there a logfile on the musicbox/rapsberry pi, where the different listings (as shown above) are kept, so I can use them in posts like this?


#10

No, please start a new thread since this one is from 2014. You will find info about log files at http://docs.pimusicbox.com/en/latest/troubleshooting/


#11

I will do so, Thanks Nick/Kingosticks, Greetings, Quintijn