Podcast Subscription

I am trying to save my podcasts subscription in the settings.ini as mentioned here http://mopidy-podcast.readthedocs.org/en/latest/config.html for some reason it is not getting recognized. any help much appreciated.

Hello Krishna,
normally subscribed podcasts are shown under Browse > Podcasts > Subscribed Feeds.
Did you refresh your browser (Ctrl + F5)?
You also can store them another way (/opt/webclient/js/streamuris.js)
regards
raspi

Hi Raspi,
Thanks for the help. I got it working by using the exact template on the http://mopidy-podcast.readthedocs.org/en/latest/config.html. But this seems to be quite unstable. Most of the time i can see the subscribed podcasts but certain times after reboot i get “Could not load ini file! Parsing failed with several errors. First error at line 189.” which is exactly the starting line of - feeds = in the ini file. any idea why this instability. I have around 40 subscriptions is it too much ?

thanks,
Krishna

Could you perhaps share the config in question? Without that we would just be guessing.

Hi
Did you manage to resolve this?
I am getting the same error.
I added this to the config.ini

# -----------
# | Podcast |
# -----------
# https://github.com/tkem/mopidy-podcast
# Play podcasts from different sources
[podcast]
# Note: You cannot add settings for [podcast-itunes] or [podcast-gpodder]
# because it breaks the startup script (won't read dashes in section names
enabled = true

# maximum number of browse results
browse_limit = 100

# maximum number of search results
search_limit = 20

# whether to return fully detailed search results; if set to "off",
# only name and URI will be returned for increased performance
search_details = off

# directory update interval in seconds
update_interval = 86400

# an optional list of podcast RSS feed URLs to subscribe to; URLs need
# to be seperated by commas or newlines
feeds =
    http://www.radioeins.de/archiv/podcast/zwei_alte_hasen.feed.podcast.xml


# user-friendly name for browsing subscribed RSS feeds
feeds_root_name = Subscribed Feeds

# number of RSS feeds to cache
feeds_cache_size = 32

# feeds cache time-to-live in seconds
feeds_cache_ttl = 3600

# HTTP request timeout in seconds
feeds_timeout = 10

I can see and play the subscribed Podcast in Brows -> Podcasts -> Subscribed Podcasts.
Howeever when I open the Setting menu I get this error message:

Could not load ini file! Invalid line (u’http://www.radioeins.de/archiv/podcast/zwei_alte_hasen.feed.podcast.xml’) (matched as neither section nor keyword) at line 177.

Which also has the result that I can no longer change some of the setting via the webinterface.

Could the problem be that this podcast is an iTunes Podcast? Because the link in the toutorial: http://www.npr.org/rss/podcast.php?id=510019 is working.

# Note: You cannot add settings for [podcast-itunes] or [podcast-gpodder]
# because it breaks the startup script (won't read dashes in section names

So basically I cant use iTunes podcasts this way?

Hope you can help me

Hi Paul,

Subscribed Podcast is very unreliable even now on pimusic box. the only
solution i got is to have only 2 or 3 subscription.

thanks,
krishna

Regards,
Krishna

The websettings is pretty rough around the edges and it probably doesn’t handle any URL in the feeds option. You could try putting it in quotation marks but I am only guessing, might not help at all. Please file an issue at https://github.com/woutervanwijk/mopidy-websettings

@Paul_Luap, it looks like you have an extra empty line between feeds = and your URL. Please try removing that.

So I got it to work by removing the new line and separating the URLs by a comma:

feeds = http://www.radioeins.de/archiv/podcast/zwei_alte_hasen.feed.podcast.xml , http://rss.dw-world.de/xml/podcast_Wissenschaft , http://rss.dw-world.de/xml/podcast_projekt-zukunft

Thanks for updating this.