Mopidy-musicbox-webclient rss podcasts

(I hope that this is the correct category for my question)

I’m running
mopidy2.0 as a service on rpi2b with jessie light + hifiberry dac+

mpd, http, mopidy-musicbox-webclient

I have been using pi musicbox (0.6) but wanted to try a more updated mopidy. The installation is working fine but I miss the possibility to listen to podcast as in musicbox. Is it possible to add podcast rss feeds to mopidy config so that they can be played with mopidy-musicbox-webclient?

To add Podcast RSS feeds, you need to install the mopidy-podcast extension. Beware, though, that the latest version no longer supports configuring feeds the same way as in MusicBox. See the docs for details.

Great job!

I installed with pip to get the latest version. Works wery well. (apt-get installed version 1.something).

I used the default Podcasts.opml. Created the file from the podcasts I had in gpodder. But its easy to manually add new pods in the opml-file.

In the mopidy-podcast docs it says that Podcasts.opml is placed in /etc/mopidy/podcast (running mopidy as service). However, in my installation it was placed instead in /var/lib/mopidy/.config/mopidy/podcast/.

Tapping a podcast retrieves a fairy long list of episodes. Do you have a plan to add a config value for the size of the list?

Thanks again,

Thanks for your feedback! Regarding the location of the config file - did you install mopidy itself from the apt repository or using pip?
As for a size limit - maybe in a future version. Dies that have a negative impact when using the Webclient?

I installed mopidy with apt.

Webclient: it takes some time before the it dsplays the episodes of a podcast. Eventually 10 seconds, since its the timeout value. Maybe I can set a lower timeout value if I’m just interested in the latest episodes.

That’s strange. When installing Mopidy as a service, its config file should be located at /etc/mopidy/mopidy.conf, and should set config_dir = /etc/mopidy.
As for the timeout, that will cancel downloading/parsing the podcast feed as a whole, so that won’t help here.

@Alexander_Jaworowski: Could you please check this settings? And how did you start Mopidy “as a service”? Using dpkg-reconfigure mopidy?

I installed mopidy following the official instructions and using apt. Since I run it as a service I have my custom settings in /etc/mopidy/mopidy.conf, i.e podcast/feeds, spotify/username etc…

I installed the service with: sudo systemctl enable mopidy

pi@mopidy2:~ $ sudo mopidyctl config
Running "/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf config" as user mopidy
cache_dir = $XDG_CACHE_DIR/mopidy
config_dir = $XDG_CONFIG_DIR/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000

Strange.When I run mopidyctl, it lists config_dir as /etc/mopidy. Maybe @jodal can shed some light on this…

I guess that you’re either:

  • running an older version of Mopidy where the core/config_dir value hasn’t been set in /etc/mopidy/mopidy.conf by the Debian package, or
  • that you had modified /etc/mopidy/mopidy.conf before upgrading to the version that changes the core/config_dir value, and thus Debian didn’t update your mopidy.conf. In that case, you might find the latest version of mopidy.conf as installed by the Debian package as /etc/mopidy/mopidy.conf.dpkg-dist.

I’m running mopidy 2.0.0 so I probably had an old config. In /etc/mopidy I have mopidy.conf.bak with these core settings:

cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy

Is there a better way to get things right than moving the present /etc/mopidy/mopidy.conf, and then reinstall mopidy and podcast? Would it suffice to copy/paste the settings in the .bak file and move the podcast folder from /var/lib/mopidy/.config/mopidy to /etc/mopidy?

Presently this is what I have in /var…

root@mopidy2:~# ls -la /var/lib/mopidy/
total 32
drwxr-xr-x  8 mopidy audio 4096 apr  2 16:53 .
drwxr-xr-x 31 root   root  4096 mar 25 20:32 ..
drwxr-xr-x  5 mopidy audio 4096 apr  2 17:59 .cache
drwxr-xr-x  4 mopidy audio 4096 apr  2 17:09 .config
drwxr-xr-x  2 mopidy audio 4096 feb 15 23:58 local
drwxr-xr-x  3 mopidy audio 4096 apr  2 16:53 .local
drwxr-xr-x  2 mopidy audio 4096 feb 15 23:58 media
drwxr-xr-x  2 mopidy audio 4096 feb 15 23:58 playlists

It should work perfectly to just copy-paste the relevant parts from mopidy.conf.bak into mopidy.conf and then:

mv /var/lib/mopidy/.config/mopidy/* /etc/mopidy

@jodal: Thanks, was too tired yesterday to think of this… So I guess this will affect pretty much anybody upgrading from Mopidy <1.1, right?

BTW, any chance you can find the time to package Mopidy-Podcast 2.0 for Debian (probably adding a /etc/mopidy/podcast dir)?