No Frontend accessible from other devices

When I start Mopidy on my Raspberry pi with default configs I can’t connect to the moped frontend when going to http://127.0.0.1:6680/moped on another device or when I try to connect from an IOS client to the server. Conecting to the server on localhost on my raspi works.This is how it starts:

INFO Starting Mopidy 0.19.4
INFO Loading config from: builtin defaults, /etc/xdg/mopidy/mopidy.conf, /home/pi/.config/mopidy/mopidy.conf, command line options
INFO Enabled extensions: mpd, http, stream, softwaremixer, moped, tunein
INFO Disabled extensions: spotify, local, radio-de
WARNING Found local configuration errors, the extension has been automatically disabled:
WARNING local/media_dir must be set.
WARNING Found radio-de configuration errors, the extension has been automatically disabled:
WARNING radio-de/language must be set.
WARNING Found spotify configuration errors, the extension has been automatically disabled:
WARNING spotify/username must be set.
WARNING spotify/password must be set.
WARNING Please fix the extension configuration errors or disable the extensions to silence these messages.
INFO Starting Mopidy mixer: SoftwareMixer
INFO Mixing using GStreamer software mixing
INFO Starting Mopidy audio
INFO Starting Mopidy backends: TuneInBackend, StreamBackend
INFO Audio output set to "autoaudiosink"
INFO Starting Mopidy core
INFO Starting Mopidy frontends: HttpFrontend, MpdFrontend
INFO HTTP server running at [::ffff:127.0.0.1]:6680
INFO MPD server running at [::ffff:127.0.0.1]:6600

Do I have to give a special IP adress or what. I can’t get it to work. I hope somebody can help me.

If you want the MPD and HTTP servers to be available outside localhost, you need to configure it so. See the following links:

Then, to connect to the server, you must use the server’s IP address or hostname, not 127.0.0.1, as that is the same as localhost, and only works from the machine running the server.

Thank you very much. Now it works. You should link these directly on the config page cause you could easily miss them.

could someone please post a working config so I can compare

There is one at the top of https://docs.mopidy.com/en/latest/config/#config

I’m also having this problem where I can connect locally but not from anywhere else on the network. The mopidy service is running and listening on port 6600 and I’ve set the hostname to both “::” and 0.0.0.0 but neither works. When I telnet to this machine on port 6600 I still get connection refused. I’ve turned off the firewall(uws and iptables) completely and I can telnet to port 80 running apache no problem.

Here is the output from netstat -tlp |egrep ‘6600|http’

Proto  Local Address      Foreign Address
tcp6    localhost:6600           [::]:*
tcp6     [::]:http               [::]:*

As you can see under the local address it looks different from apache. I’m guessing this is the problem, but how to fix it?

Hmm. Ok, so for some reason running mopidy as a service(via /etc/init.d) has this problem, but if I run it as standalone, then its fine…so perhaps there is some other config file being loaded somewhere else? Maybe this will help others…

Mopidy as a service reads config from /etc/mopidy/mopidy.conf. For details, please read https://docs.mopidy.com/en/latest/debian/#differences-when-running-as-a-system-service

Also, please open new topics instead of hijacking possibly related topics that has seen no activity for four months. Thanks!

Thank you for the response :slight_smile: Apologies for thread crashing, I just thought my experience might be relevant to others who found this through a google search as i did. will do next time :smile: