MusicBox Equalizer not affecting sound


I’m playing around getting equalizer to work for a few days now without success. I have installed equalizer and if i run a command: alsamixer -D equal it opens up and i can change frequencies but does NOT affect sound. Output is HiFBerry DAC+ card. Here are my settings


output = hifiberry_dacplus
mixer_volume = 75
output = alsasink
mixer = alsamixer
card = 1
control = PCM

root@MusicBox:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0


pcm.!default {
type plug
slave.pcm plugequal;
ctl.!default {
type hw card 0
ctl.equal {
type equal;
pcm.plugequal {
type equal;
slave.pcm “plughw:1,0”;
pcm.equal {
type plug;
slave.pcm plugequal;

I have already hack not to overvrite asound.conf on every boot.

Any suggestions?

Have you looked at

I can confirm that it works on a DAC+.


Thanks for reply. I did chek the link you send and try per manual. So i did a clean install form MusicBox, then i install sudo apt-get install -y libasound2-plugin-equal and reboot Music PI. nothing new. No equalizer, no sound difference.

Can you post complete image of MusicBox with equalizer running on it for DAC+ ?



I read post 307 more detailed now. I have Raspberry PI 2 and i can only run version 0.6 of MusicBox. I notice that there are some differences but i can’t solve it.
So are you also running 0.6 version on Raspberry PI 2?

If you take 0.6 as a starting point and apply the changes in pull request #307 you should have a working setup.

There are various ways of doing this but If you are not proficient with pip and / or git just applying the changes by hand might be the easiest.


I did find in a PULL that i have to install libasound2-plugin-equal and then i have to modify 4 files. i did exactly as described. And gues what. It is not working. Then i connect TV to Musicbox and i found an error in
line 9 “no such file or directory” /lib/lsb/init-functions

I have checked this file and exists. I have no idea how to go on. Any help please?


It might be that LSB has not been properly linked on your system.

You could try re-installing it:
sudo apt-get update sudo apt-get install --fix-missing lsb lsb-core


I did this, but i got the same error. no such file or directory /lib/lsb/init-functions
It seems i don’t understand something when i’m applying pull 307.
is there any possibility to get a working IMG for SD card? or when will be version 0.7 out?

thanks a lot


Finaly i manage to control equalizer and it is affecting sound!
i have to use this commend to open EQ:

sudo -H -u mopidy alsamixer -D equal

Thanks to all