Musicbox and Allo Boss


#1

Hi,

Just about to buy a Allo Boss DAC and thought I’d better check for compatibility with Musicbox first, I would be grateful if someone could confirm either way.

Thanks in advance…


#2

There’s currently a missing firmware issue in v0.7rc5 which stops it from working, unless you manually run the commands to update it. Someone else recently asked about this and I think I posted the commands on here someplace. Or wait for the next version (which I was planning to do last weekend but didn’t get around to).


#3

OK thanks for the reply,

I’ve been doing a bit of digging around and guess that these are the commands:

apt-get update && apt-get install --yes rpi-update
PRUNE_MODULES=1 SKIP_WARNING=1 rpi-update
reboot

If your planning on a new version I’ll probably just wait because It’s going to take me over a week to get everything in place.


#4

Just to confirm after doing the required updates, Allo Boss is available from the audio dropdown box…And works very,very well, A much bigger step up from the Pi analogue output than I would have expected and I’ve still got to wire in my new set of Tannoys yet.

Many thanks for making it possible with this awesome software…


#5

I am currently using Musicbox on Pi 3 but I was thinking of buying an Allo MiniBoss for a new project with my Pi Zero W. My question is will the smaller Allo MiniBoss DAC be compatible with the Musicbox outputs in the dropdown audio menu?


#6

Only items for Allo are Boss, Piano and Piano+ on the dropdown menu.


#7

You can just select Allo Boss as their instructions say this uses the same driver


#8

That’s great thanks…now just to have one shipped to me.


#9

Dont know if it’s related but since I’ve upgraded I seem to only be able to play single tracks from a network folder, I had this problem a while ago but that was user error (single selected in the ‘now playing’ screen) But not this time, Tried both on and off but no difference also ‘Shuffle’ doesn’t change to green when selected.


#10

Shuffle is not the same as Random.

Every time you click shuffle it’ll randomise the order of tracks in the tracklist. It’ll do that as many times as you click it. It is not stateful i.e. it is not enabled/disabled and therefore won’t “turn green”. The next track to be played will be the track after the current one in the new tracklist.

Random mode leaves the tracklist unmodified but the next track to be played will be a random track from the tracklist. If you then disable random mode the behaviour will return to picking the track after the current one in the tracklist. The order of the tracks in the tracklist will not have changed at any point.

If you are still having a problem playing the next track then please enable the mopidy debugging logging (from websettings) and provide the log. If you could also confirm that non-network share music files (e.g. files on the SD card) have the same issue or not, that’d be helpful.