Allo Boss Dac not working


#1

Hello,
I have a Raspberry Pi + ALLO BOSS DAC v1.2. And have vrious problems setting it up with pimusicbox:

  1. On the settings page I selected the boss dac from the dropdown menu and also enabled the hardware mixer. There is no sound coming from my system, though.
    It works, If I select Analog. But I obviously would like to use the allo dac.
    I have also tried setting the alsamixers volume control to digital. Didn’t work either.
    /var/log/mopidy/mopidy.log said something about "master"volume control not found (that’s why I tried “digital” which was listed as an option and the only parameter that was doing something in the alsamixer gui).
  2. Another issue I am having is, that spotify connect is not working.
  3. Additional question: is librespot using hardware volume control by default? If not is it possible to configure it that way? Otherwise the hw volume control would only work through the web frontends and not when using spotify connect.

Sorry, if this are stupid questions. I am a total beginner.
Thanks a lot in advance :slight_smile:


#2

Hi,

Take a look here, Should get you up and running
.