Music Box Just Not Working

I load up the raspberry pi and on the screen i have several warnings to do with ‘alsamizer configuration’ and the web client not being found.
I have to do something to do with extension configurations or disable the extensions to silence these messages…

I have no idea what to do…

Please include the exact warnings. It’s quite hard to help without them.
Also, the output of the command “mopidy config” would be helpful.

These are the warnings and the mopidy config results"

This is one of my first raspberry pi projects so quite new to this all.

Thank you for any help.

I know they are confusing but those particular warnings can be safely ignored. Everything there actually looks like it will work. Did you actually try connecting to the webclient?

Nothing appears when i load the ‘musicbox.local’ or use the ip version

Could it be because I do not having a premium spotify account connected to the musicbox? Is this vital in order to get it to work?

No, that should only be necessary to use the Spotify service and even if it was enabled, it shouldnt stop Mopidy from starting. Can you try to login (via USB keyboard, or by enabling SSH access in settings.ini and connecting remotely) and have a look in /var/log/mopidy/mopidy.log for any errors and also try running /etc/init.d/mopidy status to check that Mopidy is running.

If this is through the same thing that I found before, it says that that directory doesn’t exist. Same for the Mopidly status

Im not on a screen which shows the ip address and link that I got when I first tried this. Could that be linked?


Was using the wrong ip address all this time…

Thank you so much for your help anyway!

Oh! Not to worry, glad it’s now working for you. You did have me puzzled.

If you can, try getting the musicbox.local hostname to work. It’s much easier than trying to remember an IP address, only for your friend to come over and have their iPhone steal the IP address.