Troubleshooting mopidy

I installed v0.7.0 Release Candidate 6 on a Raspberry Pi Zero W, and I cannot get mopidy to serve pages reliably. Reliably as in, it worked once. I’m using a brand-name SD card (16GB, class 10) and cannot access:

http://musicbox.local/musicbox_webclient/ (again, worked once)

/var/log/mopidy/ is empty, my musicbox startup log looks normal. My config is set to ignore local files and not to scan the network for music shares (I think I have that right).

I try to see if mopidy is running:

ps aux | grep mopidy

mopidy 3507 96.3 26.0 268416 128324 ? Sl 23:18 2:10 /usr/bin/python /usr/local/bin/mopidy --quiet --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf
root 3603 0.0 0.2 1776 1148 ? S 23:20 0:00 /bin/sh /etc/init.d/mopidy stop
root 3606 2.3 0.2 1712 1244 ? S 23:20 0:00 start-stop-daemon --stop --quiet --name mopidy --pidfile /var/run/ --retry=TERM/30/KILL/5

I’m tried stopping/starting the service. Airplay works, as does Spotify Connect.

Anything else I should try next?


Have you tried accessing musicbox using it’s ip address (192.168.0.XXX) or whatever yours is.
Did you notice in the docs you may need itunes installed if on a windows computer.

I tried using just the IP address as well - I’m on a mac/Safari and it resolves .local domains (mDNS) fine with OctoPrint on a different raspberry Pi. I’ve been SSH’ing into the Pi via musicbox.local.