Mopidy Discourse

Mopidy not working after changing .conf

Hello everyone.
I just installed mopidy on my pi zero w with a pirate audio line out hat. I followed the instructions given on their website. Everything works fine up until the point where I change the mopidy.conf file for spotify. It seems that mopidy is not really able to read the config file. Is there anything I could have done wrong in the whole process?

What makes you think it can’t read the file now?

You need to look at the logs to find out what happening. How are you running Mopidy? As a service? If so the docs say to run sudo journalctl -u mopidy to see the logs.

I´m running it as a service.
I think its not woking because i cant reach the iris web client. Although sudo systemctl status mopidy states that mopidy is running.

Thats what i get from the log command:

Dec 22 19:49:59 raspberrypi systemd[1]: Starting Mopidy music server…
Dec 22 19:49:59 raspberrypi systemd[1]: Started Mopidy music server.
Dec 22 19:50:11 raspberrypi mopidy[494]: INFO [MainThread] mopidy.main Starting Mopidy 3.0.2
Dec 22 19:50:11 raspberrypi mopidy[494]: INFO [MainThread] mopidy.config Loading config from builtin defaults
Dec 22 19:50:11 raspberrypi mopidy[494]: INFO [MainThread] mopidy.config Loading config from file:///usr/share/mopidy/conf.d/mopidy.conf
Dec 22 19:50:11 raspberrypi mopidy[494]: INFO [MainThread] mopidy.config Loading config from file:///etc/mopidy/mopidy.conf
Dec 22 19:50:11 raspberrypi mopidy[494]: INFO [MainThread] mopidy.config Loading config from command line options
Dec 22 19:50:11 raspberrypi mopidy[494]: WARNING [MainThread] mopidy.config Ignoring config section ‘mpd’ because no matching extension was found
Dec 22 19:50:15 raspberrypi mopidy[494]: INFO [MainThread] mopidy.main Enabled extensions: softwaremixer, pidi, stream, spotify, iris, raspberry-gpio, file, http, m3u
Dec 22 19:50:15 raspberrypi mopidy[494]: INFO [MainThread] mopidy.main Disabled extensions: none
Dec 22 19:53:28 raspberrypi mopidy[494]: INFO [MainThread] mopidy.commands Starting Mopidy mixer: SoftwareMixer
Dec 22 19:53:28 raspberrypi mopidy[494]: INFO [MainThread] mopidy.commands Mixer volume set to 40
Dec 22 19:53:28 raspberrypi mopidy[494]: INFO [MainThread] mopidy.commands Starting Mopidy audio
Dec 22 19:53:28 raspberrypi mopidy[494]: INFO [MainThread] mopidy.commands Starting Mopidy backends: FileBackend, M3UBackend, StreamBackend, SpotifyBackend
Dec 22 19:53:28 raspberrypi mopidy[494]: WARNING [MainThread] mopidy.file.library /home/pi/Music is not a directory. Please create the directory or update the file/media_dirs config value.
Dec 22 19:53:31 raspberrypi mopidy[494]: INFO [Audio-2] mopidy.audio.actor Audio output set to “alsasink device=hw:sndrpihifiberry”
Dec 22 19:53:33 raspberrypi mopidy[494]: INFO [SpotifyEventLoop] mopidy_spotify.backend Logged in to Spotify in online mode
Dec 22 19:53:34 raspberrypi mopidy[494]: INFO [SpotifyBackend-6] mopidy_spotify.web Logged into Spotify Web API as username

That log shows Mopidy-Spotify is still loading your playlists and has not started any frontends yet. Once its done it will report how many playlists were loaded and it’ll show the interface(s) the http frontend was started on.

So my Pi is just awfully slow ?
I´m just confused because before updating the config file/rebooting, everything worked fine…

Yes, pi zeros are really slow. Enabling spotify slowed down the startup because loading the playlist data is particularly slow. The longer your playlists, the slower it is. Makes sense to me. Set allow_playlists = false if you want to convince yourself.

I will try that. Thank you in advance.

You’ll see Starting Iris 3.55.2 in the log when Iris starts.

So what i did is reinstall Mopidy and disabled the spotify plugin. Now everything works fine and i use raspotify to play music from spotify. Thank you again for your help.

I have the same experience on Rasperry Pi Zero, also on Raspi 3+. Enabling Spotify playlist seems to prevent a regular start. Maybe I am just not patient enough :laughing:

As @kingosticks recommends my solution is to disable playlists.

[spotify]
enabled = true
username = a
password = b
client_id = c
client_secret = d
allow_playlists = false

It can take several minutes to finish loading everything, depending on how much power you’ve got. If you watch the output from Mopidy as it starts you’ll be able to see what it’s doing.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.