Mopidy Discourse

Mopidy-Iris not showing my music files up

Hello, I just installed Mopidy and Mopidy-Iris on my local machine.
In the config file under [file] I added my music library.
But when I go into the Iris interface, no tracks show up. Only when I go to the Folder under “Browse” but then without a thumbnail.
My Music collection is on a remote disk mounted into my file system. I don’t know if that would be a problem.
So I thought maybe I need run a local scan and then the files will show up. Beforehands I added the Path to the /etc/sudoers file, but the error log somehow still says, that there is no entry.

This is my config file:

# For further information about options in this file see:
#   https://docs.mopidy.com/
#
# The initial commented out values reflect the defaults as of:
#   Mopidy 3.1.1
#   Mopidy-File 3.1.1
#   Mopidy-HTTP 3.1.1
#   Mopidy-M3U 3.1.1
#   Mopidy-SoftwareMixer 3.1.1
#   Mopidy-Stream 3.1.1
#
# Available options and defaults might have changed since then,
# run `mopidy config` to see the current effective config and
# `mopidy --version` to check the current version.

[core]
cache_dir = $XDG_CACHE_DIR/mopidy
config_dir = $XDG_CONFIG_DIR/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000
restore_state = true

[logging]
verbosity = 0
format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n  %(message)s
color = true
config_file =

[audio]
mixer = software
mixer_volume =
output = autoaudiosink
buffer_time =

[proxy]
#scheme = 
#hostname = 
#port = 
#username = 
#password = 

[file]
enabled = true
media_dirs =
    /mnt/unraid/2.Pool-Media/1.Audio/Musik/|Musik
excluded_file_extensions =
  .directory
  .html
  .jpeg
  .jpg
  .log
  .nfo
  .pdf
  .png
  .txt
  .zip
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[http]
#enabled = true
#hostname = 127.0.0.1
#port = 6680
#zeroconf = Mopidy HTTP server on $hostname
#allowed_origins = 
#csrf_protection = true
#default_app = mopidy

[m3u]
enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir = /mnt/unraid/2.Pool-Media/1.Audio/Musik/Mopidy/Playlists/

[softwaremixer]
enabled = true

[stream]
#enabled = true
#protocols = 
#  http
#  https
#  mms
#  rtmp
#  rtmps
#  rtsp
#metadata_blacklist = 
#timeout = 5000

I think Iris only really works well with Spotify and Local extensions. If you want to use Iris, you’ll want to use Local.

Ohh thanks, my bad. I thought file and local were the same thing. Thanks!

Yeah, it’s confusing. I haven’t used either, so I’m not sure what the difference is.

it allows you to browse through your local file system

As opposed to scanning first, like in the more traditional Mopidy-Local. One example where it might be useful is when temporarily plugging in a usd drive full of music.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.