Mopidy Discourse

Mopidy as a service does not start Iris or Local

Hey, I had Mopidy-Iris and Local working on a RPI Zero W but had to wipe the image for unrelated reasons. I tried following the tutorial to install them again but this time it does not seem to detect either extension.


Running sudo journalctl -u mopidy gives:

-- Logs begin at Tue 2020-12-29 16:44:42 MST, end at Tue 2020-12-29 16:44:45 MST. --
ec 29 16:44:42 raspberrypi mopidy[734]: INFO     Starting Mopidy 2.2.2
Dec 29 16:44:42 raspberrypi mopidy[734]: INFO     Loading config from builtin defaults
Dec 29 16:44:42 raspberrypi mopidy[734]: INFO     Loading config from /etc/mopidy/mopidy.conf
Dec 29 16:44:42 raspberrypi mopidy[734]: INFO     Loading config from command line options
Dec 29 16:44:43 raspberrypi mopidy[734]: INFO     Enabled extensions: mpd, http, stream, m3u, softwaremixer, file, local
Dec 29 16:44:43 raspberrypi mopidy[734]: INFO     Disabled extensions: none
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     Starting Mopidy mixer: SoftwareMixer
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     Starting Mopidy audio
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     Starting Mopidy backends: StreamBackend, M3UBackend, FileBackend, LocalBackend
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     Audio output set to "autoaudiosink"
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     No local library metadata cache found at /var/lib/mopidy/.local/share/mopidy/local/library.json.gz. Please run `mopidy local scan` to index your local music library. If you do not have a local music collection, you can disable the l
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     Loaded 0 local tracks using json
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     Starting Mopidy core
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     Starting Mopidy frontends: MpdFrontend, HttpFrontend
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     MPD server running at [::ffff:127.0.0.1]:6600
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     Starting GLib mainloop
Dec 29 16:44:45 raspberrypi mopidy[734]: INFO     HTTP server running at [::ffff:0.0.0.0]:6680
lines 1-24/24 (END)

Notably, only local shows up in the extensions. I realize no music has been loaded but I did try previously to add music to it and it didn’t resolve the issue. This is my second reflash of the OS. Here’s the output of sudo mopidyctl config:

Running "/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf config" as user mopidy
/usr/lib/python2.7/dist-packages/mopidy/ext.py:202: PkgResourcesDeprecationWarning: Parameters to load are deprecated.  Call .resolve and .require separately.
  extension_class = entry_point.load(require=False)
[core]
cache_dir = $XDG_CACHE_DIR/mopidy
config_dir = $XDG_CONFIG_DIR/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
color = true
console_format = %(levelname)-8s %(message)s
debug_format = %(levelname)-8s %(asctime)s [%(process)d:%(threadName)s] %(name)s\n  %(message)s
debug_file = mopidy.log
config_file =

[audio]
mixer = software
mixer_volume =
output = autoaudiosink
buffer_time =

[proxy]
scheme =
hostname =
port =
username =
password =

[mpd]
enabled = true
hostname = 127.0.0.1
port = 6600
password =
max_connections = 20
connection_timeout = 60
zeroconf = Mopidy MPD server on $hostname
command_blacklist =
  listall
  listallinfo
default_playlist_scheme = m3u

[http]
enabled = true
hostname = 0.0.0.0
port = 6680
static_dir =
zeroconf = Mopidy HTTP server on $hostname
allowed_origins =
csrf_protection = true

[stream]
enabled = true
protocols =
  http
  https
  mms
  rtmp
  rtmps
  rtsp
metadata_blacklist =
timeout = 5000

[m3u]
enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir =

[softwaremixer]
enabled = true

[file]
enabled = true
media_dirs =
  $XDG_MUSIC_DIR|Music
  ~/|Home
excluded_file_extensions =
  .jpg
  .jpeg
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[local]
enabled = true
library = json
media_dir = /home/pi/Music
scan_timeout = 1000
scan_flush_threshold = 100
scan_follow_symlinks = false
excluded_file_extensions =
  .directory
  .html
  .jpeg
  .jpg
  .log
  .nfo
  .png
  .txt

Here’s the contents of my /etc/mopidy/mopidy.conf:

[http]
hostname = 0.0.0.0

[iris]
enabled = true

[local]
media_dir = /home/pi/Music

It accepted every option except for iris. I followed the install instructions for Iris and it seems to be correctly installed?

pi@raspberrypi:~ $ sudo python3 -m pip install Mopidy-Iris
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: Mopidy-Iris in /usr/local/lib/python3.7/dist-packages (3.55.4)
Requirement already satisfied: Mopidy>=3.0 in /usr/local/lib/python3.7/dist-packages (from Mopidy-Iris) (3.1.1)
Requirement already satisfied: Pykka>=2.0.1 in /usr/local/lib/python3.7/dist-packages (from Mopidy-Iris) (2.0.3)
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (from Mopidy-Iris) (40.8.0)
Requirement already satisfied: requests>=2.0 in /usr/lib/python3/dist-packages (from Mopidy>=3.0->Mopidy-Iris) (2.21.0)
Requirement already satisfied: tornado>=4.4 in /usr/local/lib/python3.7/dist-packages (from Mopidy>=3.0->Mopidy-Iris) (6.1)

Thank you very much for the help, I’m not sure what changed between that first flash and now that’s causing it to not work.

Thats quite an old version of Mopidy and a new version of Iris. I’m not sure but I think Iris needs the latest version of Mopidy to run. Latest version is Mopidy 3.1.0 released and 11 extensions updated - General - Mopidy Discourse

Jeez that’s an embarrassing mistake! Thanks for the help, after the update everything is working smoothly. Not sure how I managed to get an old version and not update it haha.