Mopidy-Spotify Installed, but isn't started (Raspbian Buster)

As the title suggests, I’ve installed mopidy-spotify and I can get mopidy up and running. I’ve installed Mopify, which I can access and can connect to Spotify, pulling in all my playlists etc. In Mopify, if I hit Play on anything, nothing happens.

Trying Iris, I get a warning in the Spotify settings:

Mopidy-Spotify extension is not running - you will not be able to play any Spotify tracks

From running ‘mopidy config’ it doesn’t look like mopidy-spotify is being loaded at all, based on the output when I execute mopidy:

INFO Starting Mopidy 2.3.1
INFO Loading config from builtin defaults
INFO Loading config from /home/pi/.config/mopidy/mopidy.conf
INFO Loading config from command line options
INFO Enabled extensions: mopify, iris, mpd, http, m3u, softwaremixer, file, local-images, local, local-sqlite
INFO Disabled extensions: stream

Can anyone spot what I’m missing? Any help would be appreciated! Here’s my config:

[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = /var/lib/mopidy
max_tracklist_length = 10000
restore_state = false

[logging]
verbosity = 0
format = %(levelname)-8s [%(threadName)s] %(name)s %(message)s
color = false
config_file =

[audio]
mixer = software
mixer_volume =
output = autoaudiosink
buffer_time =

[proxy]
scheme =
hostname =
port =
username =
password =

[file]
enabled = true
media_dirs =
/disks/1TBbackup/
excluded_file_extensions =
.directory
.html
.jpeg
.jpg
.log
.nfo
.pdf
.png
.txt
.zip
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[http]
enabled = true
hostname = ::
port = 6680
zeroconf = Mopidy HTTP server on $hostname
allowed_origins =
csrf_protection = true
default_app = mopidy

[m3u]
enabled = true
base_dir =
default_encoding = latin-1
default_extension = .m3u8
playlists_dir =

[softwaremixer]
enabled = true

[stream]
enabled = false ; Extension disabled by user config.

[spotify]
enabled = true
username = gunforhire
password = ********
client_id = 9cf9360e-6fee-40b1-9c54-64950baabe8a
client_secret = ********
bitrate = 320
volume_normalization = true
private_session = false
timeout = 10
allow_cache = true
allow_network = true
allow_playlists = true
search_album_count = 20
search_artist_count = 10
search_track_count = 50
toplist_countries =
CA

sudo mopidyctl deps shows what extensions are installed, it’s described at http://docs.mopidy.com/en/latest/troubleshooting/.

Did you install from apt.mopidy.com or some other method?

There is also information in the docs about running as a service. The config you’ve provided looks like a service config, but you’ve executed mopidy from the terminal using your normal user i.e. not running the system service.

Now I’ve woken up a bit more I can maybe be clearer.

The latest version of Mopidy from apt.mopidy.com is Mopidy version 3.x. It requires Python 3.7+.

The Mopidy-Iris extension is not yet compatible with Python 3 and cannot be used with Mopidy v3.x.

When running the Mopidy service you’ll be running Mopidy from apt. sudo mopidyctl deps will show you the compatible extensions you have available. If you have installed Mopidy-spotify then it’ll be listed there. If you see Python 3 versions of Mopidy and it’s extensions then you will not see Iris listed there (until the new Python 3 verison is released, hopefully soon).

When running Mopidy in the terminal, in the way you have demonstrated, you have run an old Python 2 version (possibly installed from pip). That old version will see a compatible version of Iris but it won’t see any of the Python 3 extensions you installed from apt. mopidy deps will show the difference.