Mopidy and Jellyfin no Connection

Good evening everyone,

I have been trying to establish a connection between my Mopidy instance on my Raspberry Pi and the Jellyfin server for several hours, unfortunately without success.

I use Jellyfin in Docker on my Synology NAS.
I establish the connection from the PC via a domain, which is resolved via the reverse proxy of the NAS and points to the Docker application.

Alternatively, I have already tested that I release the Jellyfin port 8096 on the NAS directly and you can access the Jellyfin instance with HTTP.

I have configured Mopidy exactly according to the Jellyfin instructions:

From the section:
Raspberry Pi (Remote Controlled Speakers)

I have tried both the FQDN and the IP address of the Jellyfin server. Even with port :8096 it didn’t work…

Here are three example configurations:

enabled = true
hostname =
username = mopidy
password = Test4543
libraries = Musik

hostname =
username = mopidy
password = Test4543

hostname =
user_id = mopidy
token = 34234234234234324234234234

nothing worked :frowning:
Mopidy works though, I installed the TuneIn application and it worked straight away!

I would be very happy if someone has an idea?

Are the instructions at Jellyfin still up to date?

Best regards

Do you see any errors in the log when Mopidy is starting up, or when you try to use the extension? That should give you a clue as to the problem.

You can see all the config options available here.
It looks like there’s a port option, although I can’t see where it’s used in the code. Might be worth a try.

I make a completely new installation of raspian and now it worked. Previously i have restarted the raspberry when i have made changes to the config but it looked like they won’t applied. So i am searching and found the restart command for mopidy service and that was the game changer this applies the configuration an now it works.

Mopidy config changes take effect when you restart Mopidy. If you restart your machine, this also restarts Mopidy. There are no situations where restarting the machine does not pick up the latest config settings from the (correct) config file.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.