How to hide Files directory in clients for Mopidy 1.1.0

With Mopidy 1.1.0 (1.1.0-2 on Raspbian) I get under Directories in MPD and gmpc a folder called Files. That contains three extra empty folders called local, media and playlists. See screenshot MPD and screenshot gmpc

How can I get rid of the Files directory listing on my clients? for me it serves no purposes and it wasn’t there before with earlier version of Mopidy.

While on the subject, the new version also added more settings in Mopidy configuration file. At the moment I have

[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
#data_dir = /var/lib/mopidy

[local]
enabled = true
data_dir = /var/lib/mopidy/local
media_dir = /home/pi/usbdrv/Music

[m3u]
playlists_dir = /var/lib/mopidy/playlists

The line that is commented out seems redundant or conflicting to me as data_dir is also specified in [local]. Can some elaborate on this?

At the moment /var/lib/mopidy/playlists contains playlists and those work fine under Playlists in the clients. My /var/lib/mopidy/media is empty as all is found under media_dir. My /var/lib/mopidy/local directory holds a file called library.json.gz.

Also ncmpcpp lists these directories.

To gather all config related errors and warnings regarding data directories, in the log I see

2015-08-25 02:03:22,732 INFO [3653:MainThread] mopidy.m3u.playlists: Loaded 38 M3U playlists from /var/lib/mopidy/m3u
2015-08-25 02:03:22,739 WARNING [3653:MainThread] mopidy.file.library: Failed expanding path ($XDG_MUSIC_DIR) fromfile/media_dirs config value.
2015-08-25 02:03:25,567 INFO [3653:MainThread] mopidy.local.library: Loaded 1188 local tracks using json

How do I get rid of that warning?

Furthermore, mopidy config lists

[core]
cache_dir = /var/cache/mopidy
config_dir = /etc/mopidy
data_dir = $XDG_DATA_DIR/mopidy
max_tracklist_length = 10000


[file]
enabled = true
media_dirs = 
  $XDG_MUSIC_DIR|Music
  ~/|Home
show_dotfiles = false
follow_symlinks = false
metadata_timeout = 1000

[local]
enabled = true
library = json
media_dir = /home/pi/usbdrv/Music
data_dir = /var/lib/mopidy/local
scan_timeout = 1000
scan_flush_threshold = 1000
scan_follow_symlinks = false
excluded_file_extensions = 
  .directory
  .html
  .jpeg
  .jpg
  .log
  .nfo
  .png
  .txt

Disable Mopidy-File, which is a new bundled extension in Mopidy 1.1, in your mopidy.conf:

[file]
enabled = false

Or better, point file/media_dirs to a dir you’d like to browse by file hierarchy.

core/data_dir and local/data_dir are distinct configs and does not have the exact same semantics. You should not disable one because you have set the other. Actually, in 1.1.1 we’ll remove local/data_dir.

This sounds about right.

This warning will be fixed in 1.1.1, ref https://github.com/mopidy/mopidy/issues/1249.

Next time, please create three topics instead of braindumping all questions into one. It makes it easier to keep track of what has been responded to and not :slight_smile: