Change Media dir in config file

I am a raspbien / mopidy newbie. I have attached an ext4 hard drive, with loads of mp3s to the PI and set the contents to 777. I setup mopidy as a service and in the config
I see

media_dir = /var/lib/mopidy/media

I have changed the fstab to mount the hard drive at /var/lib/mopidy/media and restarted.

sudo mopidyctl local scan
sudo: impossible de déterminer le nom de l’hôte pimusic: Nom ou service inconnu
Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf local scan” as user mopidy
INFO Starting Mopidy 2.3.0
INFO Loading config from builtin defaults
INFO Loading config from /etc/mopidy/mopidy.conf
INFO Loading config from command line options
INFO Enabled extensions: mpd, http, moped, stream, m3u, softwaremixer, file, local
INFO Disabled extensions: none
INFO Found 0 files in media_dir.
INFO Checking 0 tracks from library.
INFO Removing 0 missing tracks.
INFO Found 0 tracks which need to be updated.
INFO Scanning…
INFO Scanned 0 of 0 files in 0s.
INFO Done scanning.

Mopidy does not see any files or folders. I was wondering if it would not be better to have the disk mount in a more classic place like /mnt/ but I cannot find a way to modify the config file. I cannot even confirm that it is scanning the right place.
Any help most welcome

I have the found the solution. I just did not read the documentation properly.

The default config is unchangable. I added the parts I wanted to change to the


I then checked that the sections had been taken into account after restarting mopidy and consulting the live config file

sudo mopidyctl config

Hope this helps someone

I change the location of the library as a matter of course. fstab is set to mount it at /mnt/media and mopidy.conf sets media_dir to point to /mnt/media. I feel like I’m missing something here.

Welcome, BTW.

In theory, it should work for you., I presume that your external files are really in the /mnt/ folder