External CD reader?

#1

Hi, I tried to add an external CD reader into a free USB port and launching a manual scan, but musicbox is not mounting it…

No way?

0 Likes

#2
root@MusicBox:~# lsusb

Bus 001 Device 004: ID 0781:5571 SanDisk Corp. Cruzer Fit

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 005: ID 0e8d:1806 MediaTek Inc. Samsung SE-208AB Slim Portable DVD Writer

Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
0 Likes

#3

This is from dmesg. The device is detected…

[  228.979314] usb 1-1.3: new high-speed USB device number 5 using dwc_otg
[  229.116804] usb 1-1.3: New USB device found, idVendor=0e8d, idProduct=1806
[  229.117600] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  229.119172] usb 1-1.3: Product: MT1887 
[  229.120012] usb 1-1.3: Manufacturer: MediaTek Inc
[  229.120827] usb 1-1.3: SerialNumber: S16D6YMG100C9M 
[  229.125386] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[  229.126430] scsi host1: usb-storage 1-1.3:1.0
[  230.152337] scsi 1:0:0:0: CD-ROM            TSSTcorp CDDVDW SE-218GN  TS00 PQ: 0 ANSI: 0
[  230.155497] scsi 1:0:0:0: Attached scsi generic sg1 type 5
[  230.184786] sr 1:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[  230.186615] cdrom: Uniform CD-ROM driver Revision: 3.20
[  230.187893] sr 1:0:0:0: Attached scsi CD-ROM sr0
0 Likes

#4

Yes way. We don’t have any support for this. A search of the forum would show CD Extension Development

1 Like

#5

Have you ever tried Mopidy-Cd?

0 Likes

#6

fmarzocca - did you ever get CDs to work? I’ve got it working on two Pi’s with Mopidy/Musicbox (or Iris)/Snapcast.

You’ve been posting in the other thread. The details of what it took for me to get it to work are there, mostly that I’m using Mopidy as a service and that the mopidy user had to be added to the cdrom group. The branch that was referenced there is working for me.

KO

0 Likes

#7

Hi KraigoMpls,

yes I finally got it working (but I am using a Mopidy installation over Debian Stretch).

Thanks

0 Likes