Control Spotify using mpc with Mopidy


I really can’t get mpc to work with Mopidy on my Raspberry Pi 2.
Everything’s configured and set up, I can even play songs using ncmpcpp.
mpc can list the Spotify playlists using lsplaylists, but if I try to mcp load a playlist (tried URI, name, …) it says
"loading: spt://spotify:user:1165115211:playlist:2j1HFZzMmJKY0A14HRcqDi
error: No such playlist".

Anny suggestions?


IIRC, mpc load loads playlists by name. Using URLs of the form spt:// will definitively not work as that is the MPD way of doing it. In Mopidy, Spotify URIs simply start with “spotify:…”. Mopidy’s Spotify support predates MPD’s Spotify support, I believe.

Tried it without the spt, too.
Thanks anyways.

I am using Mopidy on my RPi2 and it is going well. The mopidy-spotify extension reaches just fine into my Spotify playlists. Note that it only finds your playlists, not your albums–you have to create a playlist and add albums to it. I am using MPDroid on my smartphone to control playback.

Where did you get that ‘spt://’ prefix from?

Some tutorial using Despotify…
I found a solution as I can add and play songs using their URI.
Still weird that playlists don`t work.

Mopidy-spotify uses the official libspotify library. When you list the
playlists it will display the uri that you need to use when specifying a
particular one.