Can't see musicbox as upnp renderer via bubbleupnp

I’m new to musicbox (coming from volumio and osmc), installed musicbox on pi 1 and player works great (using hifiberry sounds great too). I can access via browser with ip address and also using SSH, I have setup upnp rendering option, but bubbleupnp android can’t find the musicbox renderer? Any suggestions are appreciated.

I should also note that I am using a wired connection to the pi…

It’s quite possibly a firewall bug that’s in rc4. Can you try the following commands and see if that solved it?

iptables -P INPUT ACCEPT
iptables -F
iptables -X

Bingo - problem solved - do I need to do this every time the pi reboots?

Now onto setting up minim-server on the same pi (minim-server requires java, and when I try “sudo apt-get install oracle-java7-jdk” it’s not finding the package, I might try a raspbian update first, any comments?)

In any event, thanks for the quick reply !!

Yes, but you can add the commands to the bottom of /etc/rc.local to have it execute automatically. But note that those commands are effectively disabling the firewall. This isn’t a problem for most people but you might have your own view. Disabling the firewall wil be a proper option in rc5 and there is also what I hope is a proper firewall fix that adds the missing ports. I’m sorry I don’t recall what that fix is but you can find it in the github repo.

You will need to do an ‘apt-get update’ first, did you?

Java is now installed and working after the update, I am still wrestling with an error with minim-server and am posting on their forum. Thanks again for your help.

By the way, ‘apt-get update’ just pulls down an updated list of packages from the raspbian repository. It doesn’t actually update any of your packages (like ‘apt-get upgrade’ would). You maybe did already know that but thought I’d point out the distinction just in case, doing an upgrade can leave pi musicbox in a bad state.