Can't log into google music using my mopidy server

I have been trying to set up mopidy on an old laptop. I keep getting the following error:

TypeError: login() takes exactly 4 arguments (3 given)

As far as I can tell, this is beause I don’t have a google music deviceid in my mopidy.conf file. The gmusic github page says that I should be able to leave deviceid blank, but I am not so sure…

can anyone exlpain to me how deviceid works? How do i find the deviceid of my laptop?

EDIT: OK, so I tried the log with a valid deviceid + account and am getting the same type error. Also, spotify + soundcloud + youtube are working.


There’s a few threads about the same problem in here at the moment (not being able to log into Google Music). As far as I can work out, we’re waiting for an update. There are supposed workarounds - but I’ve spent hours trying to solve and got nowhere :frowning:


I stumbled upon something that’s called Android device ID as a Parameter for play Music that should be optional. I can’t test it at the Moment, but there should be apps around to create such an ID, or try to find the one oft your phone…

Tried that using several different deviceids (there’s also a suggestion to use “test” in its place) but that didn’t work for me either.