Mopidy Discourse

Can't connect to Spotify, Mopify service is disconnected

Hi, I’m trying to make Spotify work on my Raspberry with Mopidy but it doesn’t seem to work.
I have configured Mopidy and installed all extensions, but when I try to connect to spotify in Mopify it doesn’t connect. Log from mopidy doesn’t show anything when launching:

INFO 2021-01-05 22:04:54,942 [1439:MainThread] mopidy.main
Starting Mopidy 3.1.1
INFO 2021-01-05 22:04:55,354 [1439:MainThread] mopidy.config
Loading config from builtin defaults
INFO 2021-01-05 22:04:55,363 [1439:MainThread] mopidy.config
Loading config from file:///home/pi/.config/mopidy/mopidy.conf
INFO 2021-01-05 22:04:55,367 [1439:MainThread] mopidy.config
Loading config from command line options
INFO 2021-01-05 22:04:55,742 [1439:MainThread] mopidy.main
Enabled extensions: softwaremixer, http, spotify, mopify, stream, m3u, musicbox_webclient, mpd, local, file
INFO 2021-01-05 22:04:55,742 [1439:MainThread] mopidy.main
Disabled extensions: none
INFO 2021-01-05 22:04:56,111 [1439:MainThread] mopidy.commands
Starting Mopidy mixer: SoftwareMixer
INFO 2021-01-05 22:04:56,116 [1439:MainThread] mopidy.commands
Starting Mopidy audio
INFO 2021-01-05 22:04:56,123 [1439:MainThread] mopidy.commands
Starting Mopidy backends: FileBackend, M3UBackend, StreamBackend, SpotifyBackend, LocalBackend
INFO 2021-01-05 22:04:56,156 [1439:Audio-2] mopidy.audio.actor
Audio output set to “autoaudiosink”
INFO 2021-01-05 22:04:57,111 [1439:SpotifyEventLoop] mopidy_spotify.backend
Logged in to Spotify in online mode
INFO 2021-01-05 22:04:57,173 [1439:SpotifyBackend-6] mopidy_spotify.web
Logged into Spotify Web API as 312ygwvljogojk24gzjwoit4mn4m
INFO 2021-01-05 22:04:57,235 [1439:SpotifyBackend-6] mopidy_spotify.playlists
Refreshed 0 Spotify playlists
INFO 2021-01-05 22:04:57,236 [1439:MainThread] mopidy.commands
Starting Mopidy core
INFO 2021-01-05 22:04:57,268 [1439:MainThread] mopidy.commands
Starting Mopidy frontends: QueueManagerFrontend, HttpFrontend, MpdFrontend
INFO 2021-01-05 22:04:57,272 [1439:HttpFrontend-13] mopidy.http.actor
HTTP server running at [::ffff:0.0.0.0]:6680
INFO 2021-01-05 22:04:57,275 [1439:MainThread] mopidy_mpd.actor
MPD server running at [::]:6600
INFO 2021-01-05 22:04:57,278 [1439:MainThread] mopidy.commands
Starting GLib mainloop

but when I try to use Mopify it says:

INFO 2021-01-05 22:10:59,554 [1439:SpotifyBackend-6] mopidy_spotify.lookup
Failed to lookup ‘spotify:library:songs’: Could not parse ‘spotify:library:songs’ as a Spotify URI

I don’t know what to do, newbie here, please help!

If that’s mopify trying to load that then it’s their bug because it makes no sense. Try a different webclient.

tried mobile client, it gives another error: cannot connect to Gstreamer.
If I run sudo mopidy the mobile client works. Mopify still doesn’t work.
Ran out of ideas (no Linux expert)

I am a bit confused.

You mean you tried Mopidy-Mobile? To be clearer, I was suggesting you install and try a different web client, such as one of those listed at https://mopidy.com/ext/.

Which client you use will have zero impact on any GStreamer issues on the Mopidy server. Running sudo mopidy is not a supported method to run Mopidy, the supported methods are documented.