Can't access interface of pi music box anymore


I’ve been using the i music box for a while but I don’t seem to be able to access the Pi MusicBox home screen from my brwoser (Chrome or Firefox) anymore. I don’t want could have triggered this, the latest thing I installed was a apache http thing for wordpress.

Every time I try to access the pi music box, I have

This webpage is not available


I can access the box fine with ssh and from my android phone.

I tried stopping the apache service with apachectl stop but I still can’t reach the interface. I tried looking into the access log and error log but I didn’t see any entry for the hour I tried to get to musicbox. :confused:

You’ll probably need to try disabling apache (rather than just stopping it)
and then rebooting.

Interesting. I have recently broken my PiMB installation on a Raspberry Pi as well after I installed Apache2 in order to run a web-GUI for the youtube-dl python program running in the same RPi.

Originally I thought it was a port conflict but after a lot of mucking about I ended up making the situation worse as the mopidy process kept crashing and relaunching over and over again.

I then reformatted the SD card and started from scratch but haven’t had to reconfigure everything and test it yet.

Other than port conflicts, are there any known issues running Apache2 in the same box as Musicbox?

Mopidy may not be starting correctly and monit (the process monitor) may be causing it keep restarting in a loop. When you say ‘crashing’ do you mean crashing or do you mean failing to start and reporting an error? Running Apache, even on port 80, should not effect Mopidy’s startup. Any port conflict issues should only arise once you send a web request and it doesn’t go to the correct service.

I was monitoring the mopidy process with “top” and I could see it crash after 30 seconds or so. Audio would be interrupted as well.

I was able to reinstall and get it working again but I noticed something.

When I flashed the SD card with PiMB 0.6.0 on Raspbian, I was able to install it but the web UI wasn’t coming up at all even with all the necessary config in place.

Because I’ve had the same issue with other images, I decided to flash it again on Windows using a program called Image Writer and this time around it worked just fine.

I will try to install apache2 and that web interface again and see if I can get it to work again. I’ll update this thread once I get around to do it.

I don’t think it has anything to do with using windows. It’s the luck of the draw. I had a system working fine and then one day no web gui. Did several reflashes, then all is good. There is a bug in there somewhere and I really wish we could debug it as you never know when it will strike.

It could and it could not be. The only reason I said that is because I’ve had the same problem flashing different Distros for the RPi on Linux itself but when I do it on windows it always works flawlessly.

Hi There,

To revive an old thread…I just installed MusicBox, and successfully accessed the web interface…but only once! After rebooting the Pi, I can ping the IP address but simply cannot connect to the web service. Restarted several times without success. Has this been resolved since these 2015 posts?


Unless you also installed apache I don’t think this will be the same problem so probably better off in your own thread rather than this old one. It’s just confusing.